aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/zlib
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-03-11 09:32:19 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2017-07-14 08:45:55 +0200
commit462ca4e059dbead678163da26fb4e14748f3021e (patch)
treecfff624509e1e4f24a871343c8434ccca663f9af /package/libs/zlib
parentb3cba687a447478253f95febf17fa9376c98105d (diff)
downloadupstream-462ca4e059dbead678163da26fb4e14748f3021e.tar.gz
upstream-462ca4e059dbead678163da26fb4e14748f3021e.tar.bz2
upstream-462ca4e059dbead678163da26fb4e14748f3021e.zip
zlib: use default Build/Configure rule
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/libs/zlib')
-rw-r--r--package/libs/zlib/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/package/libs/zlib/Makefile b/package/libs/zlib/Makefile
index 902381bdea..7e3bd83195 100644
--- a/package/libs/zlib/Makefile
+++ b/package/libs/zlib/Makefile
@@ -45,17 +45,15 @@ define Package/zlib-dev/description
This package includes the development support files.
endef
-define Build/Configure
- (cd $(PKG_BUILD_DIR); \
- $(TARGET_CONFIGURE_OPTS) \
- LDSHARED="$(TARGET_CC) -shared -Wl,-soname,libz.so.1" \
- CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
- ./configure \
- --prefix=/usr \
- --shared \
- --uname=Linux \
- );
-endef
+CONFIGURE_VARS := \
+ $(TARGET_CONFIGURE_OPTS) \
+ LDSHARED="$(TARGET_CC) -shared -Wl,-soname,libz.so.1" \
+ CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
+
+CONFIGURE_ARGS := \
+ --prefix=/usr \
+ --shared \
+ --uname=Linux \
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \