aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/wolfssl
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-05-31 00:34:15 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-05-31 00:38:16 +0200
commitdad39249fb91d6f320256ac12944863f09bb2dc9 (patch)
tree5e2278d0edebbbcb6e36df472cd1d409b82e000f /package/libs/wolfssl
parenta70a0a529ff2ecb6d8f124df89fd973bed2d3138 (diff)
downloadupstream-dad39249fb91d6f320256ac12944863f09bb2dc9.tar.gz
upstream-dad39249fb91d6f320256ac12944863f09bb2dc9.tar.bz2
upstream-dad39249fb91d6f320256ac12944863f09bb2dc9.zip
wolfssl: change defaults to cover wpa_supplicant needs
Implicetely selecting the required options via Kconfig snippet from hostapd worked fine in local builds when using menuconfig but confused the buildbots which (in phase1) may build wpad-mini and hence already come with CONFIG_WPA_WOLFSSL being defined as unset which then won't trigger changing the defaults of wolfssl. Work around by explicitely reflecting wpa_supplicant's needs in wolfssl's default settings to make buildbots happy. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/libs/wolfssl')
-rw-r--r--package/libs/wolfssl/Config.in18
-rw-r--r--package/libs/wolfssl/Makefile2
2 files changed, 10 insertions, 10 deletions
diff --git a/package/libs/wolfssl/Config.in b/package/libs/wolfssl/Config.in
index 9b88914516..50b0bb9cdf 100644
--- a/package/libs/wolfssl/Config.in
+++ b/package/libs/wolfssl/Config.in
@@ -2,11 +2,11 @@ if PACKAGE_libwolfssl
config WOLFSSL_HAS_AES_CCM
bool "Include AES-CCM support"
- default n
+ default y
config WOLFSSL_HAS_AES_GCM
bool "Include AES-GCM support"
- default n
+ default y
config WOLFSSL_HAS_CHACHA
bool "Include ChaCha cipher suite support"
@@ -18,23 +18,23 @@ config WOLFSSL_HAS_ECC
config WOLFSSL_HAS_DH
bool "Include DH (Diffie-Hellman) support"
- default n
+ default y
config WOLFSSL_HAS_ARC4
bool "Include ARC4 support"
- default n
+ default y
config WOLFSSL_HAS_DES3
bool "Include DES3 (Tripple-DES) support"
- default n
+ default y
config WOLFSSL_HAS_PSK
bool "Include PKS (Pre Share Key) support"
- default n
+ default y
config WOLFSSL_HAS_SESSION_TICKET
bool "Include session ticket support"
- default n
+ default y
config WOLFSSL_HAS_DTLS
bool "Include DTLS support"
@@ -42,11 +42,11 @@ config WOLFSSL_HAS_DTLS
config WOLFSSL_HAS_OCSP
bool "Include OSCP support"
- default n
+ default y
config WOLFSSL_HAS_WPAS
bool "Include wpa_supplicant support"
- default n
+ default y
config WOLFSSL_HAS_ECC25519
bool "Include ECC Curve 22519 support"
diff --git a/package/libs/wolfssl/Makefile b/package/libs/wolfssl/Makefile
index 8c0b8617ca..e08b6f3929 100644
--- a/package/libs/wolfssl/Makefile
+++ b/package/libs/wolfssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=wolfssl
PKG_VERSION:=3.14.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
# PKG_SOURCE_URL:=https://www.wolfssl.com/