aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/wolfssl
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2020-05-26 10:45:22 -0300
committerPetr Štetiar <ynezz@true.cz>2020-06-03 16:49:28 +0200
commit750d52f6c90e2a144c250779741607f0cb306a94 (patch)
treed0e4613659716a3995def5e623be0cc40235a717 /package/libs/wolfssl
parenta9f712a79b700400286ede2671c879f42b9ebb6b (diff)
downloadupstream-750d52f6c90e2a144c250779741607f0cb306a94.tar.gz
upstream-750d52f6c90e2a144c250779741607f0cb306a94.tar.bz2
upstream-750d52f6c90e2a144c250779741607f0cb306a94.zip
wolfssl: use -fomit-frame-pointer to fix asm error
32-bit x86 fail to compile fast-math feature when compiled with frame pointer, which uses a register used in a couple of inline asm functions. Previous versions of wolfssl had this by default. Keeping an extra register available may increase performance, so it's being restored for all architectures. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'package/libs/wolfssl')
-rw-r--r--package/libs/wolfssl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libs/wolfssl/Makefile b/package/libs/wolfssl/Makefile
index b186a087e7..159cfbc53f 100644
--- a/package/libs/wolfssl/Makefile
+++ b/package/libs/wolfssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=wolfssl
PKG_VERSION:=4.4.0-stable
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
@@ -56,7 +56,7 @@ define Package/libwolfssl/config
source "$(SOURCE)/Config.in"
endef
-TARGET_CFLAGS += $(FPIC) -DFP_MAX_BITS=8192
+TARGET_CFLAGS += $(FPIC) -DFP_MAX_BITS=8192 -fomit-frame-pointer
# --enable-stunnel needed for OpenSSL API compatibility bits
CONFIGURE_ARGS += \