aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/ustream-ssl
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2017-08-24 08:56:40 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2017-09-17 00:00:12 +0200
commitd03c23c8d4d022288106979e7ce2839c9ec9c7fb (patch)
tree441c62aa13905360cfed9e1e8a6a0e39ae0918e7 /package/libs/ustream-ssl
parent560b7334ec6337d1d73225727f998a9b706c9ff6 (diff)
downloadupstream-d03c23c8d4d022288106979e7ce2839c9ec9c7fb.tar.gz
upstream-d03c23c8d4d022288106979e7ce2839c9ec9c7fb.tar.bz2
upstream-d03c23c8d4d022288106979e7ce2839c9ec9c7fb.zip
cyassl,curl,libustream-ssl: rename every `cyassl` to `wolfssl`
This is to eliminate any ambiguity about the cyassl/wolfssl lib. The rename happened some time ago (~3+ years). As time goes by, people will start to forget cyassl and start to get confused about the wolfSSL vs cyassl thing. It's a good idea to keep up with the times (moving forward). Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'package/libs/ustream-ssl')
-rw-r--r--package/libs/ustream-ssl/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/package/libs/ustream-ssl/Makefile b/package/libs/ustream-ssl/Makefile
index ff6c4b7d01..7afbeeba66 100644
--- a/package/libs/ustream-ssl/Makefile
+++ b/package/libs/ustream-ssl/Makefile
@@ -35,11 +35,11 @@ define Package/libustream-openssl
VARIANT:=openssl
endef
-define Package/libustream-cyassl
+define Package/libustream-wolfssl
$(Package/libustream/default)
- TITLE += (cyassl)
- DEPENDS += +PACKAGE_libustream-cyassl:libcyassl
- VARIANT:=cyassl
+ TITLE += (wolfssl)
+ DEPENDS += +PACKAGE_libustream-wolfssl:libwolfssl
+ VARIANT:=wolfssl
endef
define Package/libustream-mbedtls
@@ -50,7 +50,7 @@ define Package/libustream-mbedtls
DEFAULT_VARIANT:=1
endef
-ifeq ($(BUILD_VARIANT),cyassl)
+ifeq ($(BUILD_VARIANT),wolfssl)
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/cyassl -DHAVE_SNI
CMAKE_OPTIONS += -DCYASSL=on
endif
@@ -64,9 +64,9 @@ define Package/libustream/default/install
endef
Package/libustream-openssl/install = $(Package/libustream/default/install)
-Package/libustream-cyassl/install = $(Package/libustream/default/install)
+Package/libustream-wolfssl/install = $(Package/libustream/default/install)
Package/libustream-mbedtls/install = $(Package/libustream/default/install)
$(eval $(call BuildPackage,libustream-mbedtls))
-$(eval $(call BuildPackage,libustream-cyassl))
+$(eval $(call BuildPackage,libustream-wolfssl))
$(eval $(call BuildPackage,libustream-openssl))