aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/uclient
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-19 22:41:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-19 22:41:31 +0000
commit23541c6f6fc5065a6e078820e207e1ecc4ede659 (patch)
treefccfa0c5a95492abb7bf355b3c023d9935f1e8be /package/libs/uclient
parent977948b15c9116879f160df90274bd1f317e54c3 (diff)
downloadupstream-23541c6f6fc5065a6e078820e207e1ecc4ede659.tar.gz
upstream-23541c6f6fc5065a6e078820e207e1ecc4ede659.tar.bz2
upstream-23541c6f6fc5065a6e078820e207e1ecc4ede659.zip
uclient: install a symlink from uclient-fetch to wget into /bin
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48379
Diffstat (limited to 'package/libs/uclient')
-rw-r--r--package/libs/uclient/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/libs/uclient/Makefile b/package/libs/uclient/Makefile
index 7ed7ae2ff2..bc5fc114cd 100644
--- a/package/libs/uclient/Makefile
+++ b/package/libs/uclient/Makefile
@@ -43,8 +43,9 @@ define Package/libuclient/install
endef
define Package/uclient-fetch/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/uclient-fetch $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/uclient-fetch $(1)/bin/
+ ln -s uclient-fetch $(1)/bin/wget
endef
$(eval $(call BuildPackage,libuclient))