aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/uclibc++
diff options
context:
space:
mode:
authorWren Turkal <wt@penguintechs.org>2020-05-25 14:05:51 -0700
committerPetr Štetiar <ynezz@true.cz>2020-07-08 16:07:05 +0200
commit9f020269332d50dba61f5bce5f1d055b683b059e (patch)
treebbcd4645defa1eb4884c7315f20d7bb6f7647a3e /package/libs/uclibc++
parent53a1fede1f9856b61092ce4693e7610a515d562b (diff)
downloadupstream-9f020269332d50dba61f5bce5f1d055b683b059e.tar.gz
upstream-9f020269332d50dba61f5bce5f1d055b683b059e.tar.bz2
upstream-9f020269332d50dba61f5bce5f1d055b683b059e.zip
uclibc++: make verbosity affect uClibc++ build
Before this change, setting the verbosity to anything with V=blah would cause uclibc++ build to print errors to the screen. Now, it the clibc++ build verbosity will be altered in the following manners: * V=s will set V=1 in the uclibc++ build * V=sc will set V=2 in the uclibc++ build Signed-off-by: Wren Turkal <wt@penguintechs.org>
Diffstat (limited to 'package/libs/uclibc++')
-rw-r--r--package/libs/uclibc++/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/libs/uclibc++/Makefile b/package/libs/uclibc++/Makefile
index 7a0d9094ff..0e3210a5b9 100644
--- a/package/libs/uclibc++/Makefile
+++ b/package/libs/uclibc++/Makefile
@@ -55,6 +55,14 @@ ifeq ($(CONFIG_USE_MUSL),y)
SSP_LIB=-lssp_nonshared
endif
+ifeq (${V}, s)
+MAKE_VARS+= \
+ V=1
+else ifeq (${V}, sc)
+MAKE_VARS+= \
+ V=2
+endif
+
MAKE_FLAGS:= \
$(TARGET_CONFIGURE_OPTS) \
CPU_CFLAGS="$(TARGET_CFLAGS)" \