aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain
diff options
context:
space:
mode:
authorChen Minqiang <ptpt52@gmail.com>2019-04-17 20:00:49 +0800
committerJo-Philipp Wich <jo@mein.io>2020-06-18 20:08:18 +0200
commita57fb86d6a28c5292ca2ee50f2b5ec8e49c844ec (patch)
treea95eee1459a7ef977f7d28b07cd4a51c2ab11a73 /package/libs/toolchain
parentc5bf9a8ced6567c6bd9da63c6ff4c4f2f87207fd (diff)
downloadupstream-a57fb86d6a28c5292ca2ee50f2b5ec8e49c844ec.tar.gz
upstream-a57fb86d6a28c5292ca2ee50f2b5ec8e49c844ec.tar.bz2
upstream-a57fb86d6a28c5292ca2ee50f2b5ec8e49c844ec.zip
toolchain: glibc ldd env path fixup
This replace the shell script header of ldd when it install to `/usr/bin/ldd` where `#! /..../staging_dir/host/bin/bash` should be `#!/bin/sh` Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
Diffstat (limited to 'package/libs/toolchain')
-rw-r--r--package/libs/toolchain/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index f92a1779da..9851a5f1cd 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -614,6 +614,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/ldd/install
$(INSTALL_DIR) $(1)/usr/bin/
$(CP) $(TOOLCHAIN_DIR)/bin/ldd $(1)/usr/bin/
+ sed -i 's,^#!.*,#!/bin/sh,' $(1)/usr/bin/ldd
endef
define Package/ldconfig/install