aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-03-02 11:37:29 -0800
committerFlorian Fainelli <f.fainelli@gmail.com>2017-03-04 11:19:56 -0800
commit7f0c95a7dfff8aa0b6f5e3e78263cab108245e4c (patch)
treeac6362677b8aa769cc11dad6a670d868fb8c954a /package/libs/toolchain
parent6debeaab45a08d52cc018b1e5bc69924d9b41d6d (diff)
downloadupstream-7f0c95a7dfff8aa0b6f5e3e78263cab108245e4c.tar.gz
upstream-7f0c95a7dfff8aa0b6f5e3e78263cab108245e4c.tar.bz2
upstream-7f0c95a7dfff8aa0b6f5e3e78263cab108245e4c.zip
toolchain: Allow external toolchains to specify libthread-db
We need to let external toolchains be able to specify the path and specification file to the libthread-db POSIX thread debugging shared libraries. This fixes GDB not being able to be installed because it is depending on libthread-db: Collected errors: * satisfy_dependencies_for: Cannot satisfy the following dependencies * for gdb: * libthread-db * * opkg_install_cmd: Cannot install package gdb. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/libs/toolchain')
-rw-r--r--package/libs/toolchain/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index cf4a209054..8a90b5eda6 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -202,6 +202,26 @@ $(call Package/libc/Default)
TITLE:=POSIX thread library debugging support
endef
+define Package/libthread-db/config
+ menu "Configuration"
+ depends on EXTERNAL_TOOLCHAIN && PACKAGE_libthread-db
+
+ config LIBTHREAD_DB_ROOT_DIR
+ string
+ prompt "POSIX thread debugging shared library base directory"
+ depends on EXTERNAL_TOOLCHAIN && PACKAGE_libthread-db
+ default TOOLCHAIN_ROOT if !NATIVE_TOOLCHAIN
+ default "/" if NATIVE_TOOLCHAIN
+
+ config LIBTHREAD_DB_FILE_SPEC
+ string
+ prompt "POSIX thread debugging shared library files (use wildcards)"
+ depends on EXTERNAL_TOOLCHAIN && PACKAGE_libthread-db
+ default "./lib/libthread_db{-*.so,.so.*}"
+
+ endmenu
+endef
+
define Package/librt
$(call Package/libc/Default)
TITLE:=POSIX.1b RealTime extension library
@@ -517,6 +537,14 @@ else
exit 0
endef
+ define Package/libthread-db/install
+ for file in $(call qstrip,$(CONFIG_LIBTHREAD_DB_FILE_SPEC)); do \
+ $(INSTALL_DIR) $(1)/lib ; \
+ $(CP) $(call qstrip,$(CONFIG_LIBTHREAD_DB_ROOT_DIR))/$$$$file $(1)/lib/ ; \
+ done ; \
+ exit 0
+ endef
+
define Package/librt/install
for file in $(call qstrip,$(CONFIG_LIBRT_FILE_SPEC)); do \
$(INSTALL_DIR) $(1)/lib ; \