aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-12-31 16:13:35 -0800
committerFlorian Fainelli <f.fainelli@gmail.com>2017-01-29 11:51:02 -0800
commit200d932322f3d8c436a67c53f4fbca87f0aab8af (patch)
treeaa83534a331982343aff045d1dbfc8c4bea9e358 /package/libs/toolchain
parent57657a72376000b5843367e627098f09fe9c3647 (diff)
downloadupstream-200d932322f3d8c436a67c53f4fbca87f0aab8af.tar.gz
upstream-200d932322f3d8c436a67c53f4fbca87f0aab8af.tar.bz2
upstream-200d932322f3d8c436a67c53f4fbca87f0aab8af.zip
toolchain: Broaden the executable loader pattern
Some toolchains will produce executables with an interpreter that is e.g: ld.so.1 (typically a symbolic link). Due to our current LIBC_SPEC_FILE value, we would not be able to copy this symbolic link/file over to the rootfs and executables would fail to load. Extend the search pattern to include all ld*.so* files that could be needed. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/libs/toolchain')
-rw-r--r--package/libs/toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 0101b81a31..4822ca7be3 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -164,7 +164,7 @@ define Package/libc/config
string
prompt "libc shared library files (use wildcards)"
depends on EXTERNAL_TOOLCHAIN && PACKAGE_libc
- default "./lib/ld{-*.so,-linux*.so.*} ./lib/lib{anl,c,cidn,crypt,dl,m,nsl,nss_dns,nss_files,resolv,util}{-*.so,.so.*}"
+ default "./lib/ld{*.so*,-linux*.so.*} ./lib/lib{anl,c,cidn,crypt,dl,m,nsl,nss_dns,nss_files,resolv,util}{-*.so,.so.*}"
endmenu
endef