aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2019-08-16 01:33:58 -0300
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-17 16:57:32 +0200
commit0d0617ff14b8b020896680de1f1a49c7ba8a5e0d (patch)
tree4d5ba8403878d68a24986dab76345009a7431da6 /package/libs/toolchain
parentdc451a4b24b2096fe33eb7fa136614597cd601d5 (diff)
downloadupstream-0d0617ff14b8b020896680de1f1a49c7ba8a5e0d.tar.gz
upstream-0d0617ff14b8b020896680de1f1a49c7ba8a5e0d.tar.bz2
upstream-0d0617ff14b8b020896680de1f1a49c7ba8a5e0d.zip
musl: ldso/dlsym: fix mips returning undef dlsym
This happens only the second time a library is loaded by dlopen(). After lib1 is loaded, dlsym(lib1,"undef1") correctly resolves the undef symbol from lib1 dependencies. After the second library is loaded, dlsym(lib2,"undef1") was returning the address of "undef1" in lib2 instead of searching lib2 dependencies. Using upstream fix which now uses the same logic for relocation time and dlsym. Fixes openwrt/packages#9297 Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'package/libs/toolchain')
-rw-r--r--package/libs/toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index d76b0a875c..a63746c448 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=toolchain
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=GPL-3.0-with-GCC-exception