aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/toolchain
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-17 13:58:03 +0000
committerJohn Crispin <john@openwrt.org>2015-01-17 13:58:03 +0000
commit09a08fb9e6bdeee22f62f043384b638630c4ff1a (patch)
tree3ce770b29541141965e2b7a5a0fe5959ae866eee /package/libs/toolchain
parentff3448adaa7ec9be964f20f1f5095b8082aa1b19 (diff)
downloadupstream-09a08fb9e6bdeee22f62f043384b638630c4ff1a.tar.gz
upstream-09a08fb9e6bdeee22f62f043384b638630c4ff1a.tar.bz2
upstream-09a08fb9e6bdeee22f62f043384b638630c4ff1a.zip
toolchain: Add libatomic when using external toolchain
Otherwise libatomic cannot be used in conjunction with external toolchains. Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com> SVN-Revision: 43998
Diffstat (limited to 'package/libs/toolchain')
-rw-r--r--package/libs/toolchain/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 1a75e90c30..42b9935148 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -604,6 +604,15 @@ else
exit 0
endef
+ define Package/libatomic/install
+ for file in $(call qstrip,$(CONFIG_LIBATOMIC_FILE_SPEC)); do \
+ dir=`dirname $$$$file` ; \
+ $(INSTALL_DIR) $(1)/$$$$dir ; \
+ $(CP) $(call qstrip,$(CONFIG_LIBATOMIC_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
+ done ; \
+ exit 0
+ endef
+
define Package/ldd/install
for file in $(call qstrip,$(CONFIG_LDD_FILE_SPEC)); do \
dir=`dirname $$$$file` ; \