aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/readline
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-06-24 13:58:56 +0200
committerDaniel Golle <daniel@makrotopia.org>2017-06-24 14:38:14 +0200
commit04063820e85831e4f623faf395323e3e48b18b7d (patch)
tree88553f7e07d821d2e8294673467b78fb1bb81ea3 /package/libs/readline
parent991899cc5449d8595593a66c0130fdcaa088b36a (diff)
downloadupstream-04063820e85831e4f623faf395323e3e48b18b7d.tar.gz
upstream-04063820e85831e4f623faf395323e3e48b18b7d.tar.bz2
upstream-04063820e85831e4f623faf395323e3e48b18b7d.zip
libreadline: add host-build
Also make sure that the PKG_NAME and folder name are equal. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/libs/readline')
-rw-r--r--package/libs/readline/Makefile74
-rw-r--r--package/libs/readline/patches/001-install_perm.patch11
2 files changed, 85 insertions, 0 deletions
diff --git a/package/libs/readline/Makefile b/package/libs/readline/Makefile
new file mode 100644
index 0000000000..ccd20a4b18
--- /dev/null
+++ b/package/libs/readline/Makefile
@@ -0,0 +1,74 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=readline
+PKG_VERSION:=7.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/readline
+PKG_HASH:=750d437185286f40a369e1e4f4764eda932b9459b5ec9a731628393dd3d32334
+
+PKG_LICENSE:=GPL-3.0
+PKG_LICENSE_FILES:=COPYING
+
+PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+define Package/libreadline
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Command lines edition library
+ URL:=http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
+ ABI_VERSION:=$(PKG_VERSION)
+endef
+
+define Package/libreadline/description
+ The Readline library provides a set of functions for use by applications
+ that allow users to edit command lines as they are typed in. Both Emacs
+ and vi editing modes are available. The Readline library includes
+ additional functions to maintain a list of previously-entered command
+ lines, to recall and perhaps reedit those lines, and perform csh-like
+ history expansion on previous commands.
+endef
+
+# prevent "autoreconf" from removing "aclocal.m4"
+PKG_REMOVE_FILES:=
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --with-curses \
+
+CONFIGURE_VARS += \
+ bash_cv_wcwidth_broken=no \
+ bash_cv_func_sigsetjmp=yes \
+
+TARGET_CPPFLAGS:=-I. -I.. $(TARGET_CPPFLAGS)
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/readline $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{a,so,so.7,so.7.0} $(1)/usr/lib/
+endef
+
+define Package/libreadline/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{history,readline}.{so,so.7,so.7.0} $(1)/usr/lib/
+endef
+
+$(eval $(call HostBuild))
+$(eval $(call BuildPackage,libreadline))
diff --git a/package/libs/readline/patches/001-install_perm.patch b/package/libs/readline/patches/001-install_perm.patch
new file mode 100644
index 0000000000..951ff73e5b
--- /dev/null
+++ b/package/libs/readline/patches/001-install_perm.patch
@@ -0,0 +1,11 @@
+--- a/support/shlib-install
++++ b/support/shlib-install
+@@ -73,7 +73,7 @@ fi
+ case "$host_os" in
+ hpux*|darwin*|macosx*|linux*|solaris2*)
+ if [ -z "$uninstall" ]; then
+- chmod 555 ${INSTALLDIR}/${LIBNAME}
++ chmod +x ${INSTALLDIR}/${LIBNAME}
+ fi ;;
+ cygwin*|mingw*)
+ IMPLIBNAME=`echo ${LIBNAME} \