aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2019-01-30 08:42:11 -0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-12 22:24:09 +0100
commit29b69e840a44fad518d9d9ecd93966d0d2a4f076 (patch)
tree53a4a7d6c14390ca21f3e076d37f304a7374e829 /package/libs/openssl
parent2eeb2853ed3199c3bb65d3498e02ac36526befb4 (diff)
downloadupstream-29b69e840a44fad518d9d9ecd93966d0d2a4f076.tar.gz
upstream-29b69e840a44fad518d9d9ecd93966d0d2a4f076.tar.bz2
upstream-29b69e840a44fad518d9d9ecd93966d0d2a4f076.zip
openssl: add package for openssl.cnf, misc changes
- Add the /etc/ssl/openssl.cnf as a separate package, to avoid breaking the transitional mechanism, allowing libopenssl_1.0* and libopenssl_1.1* to coexist. - Remove the (selecting) dependency on @KERNEL_AIO - Use global SOURCE_DATE_EPOCH Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'package/libs/openssl')
-rw-r--r--package/libs/openssl/Config.in4
-rw-r--r--package/libs/openssl/Makefile32
2 files changed, 28 insertions, 8 deletions
diff --git a/package/libs/openssl/Config.in b/package/libs/openssl/Config.in
index c9a853193f..3ad8a66b9e 100644
--- a/package/libs/openssl/Config.in
+++ b/package/libs/openssl/Config.in
@@ -250,11 +250,14 @@ config OPENSSL_ENGINE
This enables alternative cryptography implementations,
most commonly for interfacing with external crypto devices,
or supporting new/alternative ciphers and digests.
+ Note that you need to enable KERNEL_AIO to be able to build the
+ afalg engine package.
config OPENSSL_ENGINE_CRYPTO
bool
select OPENSSL_ENGINE
select PACKAGE_kmod-cryptodev
+ select PACKAGE_libopenssl-conf
prompt "Acceleration support through /dev/crypto"
help
This enables use of hardware acceleration through OpenBSD
@@ -284,4 +287,3 @@ config OPENSSL_WITH_GOST
https://github.com/gost-engine/engine
endif
-
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 68cd8fde6b..732e3eb1cb 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -104,24 +104,37 @@ define Package/openssl-util
$(call Package/openssl/Default)
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+libopenssl
+ DEPENDS:=+libopenssl +libopenssl-conf
TITLE+= (utility)
endef
-define Package/openssl-util/conffiles
+define Package/openssl-util/description
+$(call Package/openssl/Default/description)
+This package contains the OpenSSL command-line utility.
+endef
+
+define Package/libopenssl-conf
+ $(call Package/openssl/Default)
+ SUBMENU:=SSL
+ TITLE:=/etc/ssl/openssl.cnf config file
+ DEPENDS:=libopenssl
+endef
+
+define Package/libopenssl-conf/conffiles
/etc/ssl/openssl.cnf
endef
-define Package/openssl-util/description
+define Package/libopenssl-conf/description
$(call Package/openssl/Default/description)
-This package contains the OpenSSL command-line utility.
+This package installs the OpenSSL configuration file /etc/ssl/openssl.cnf.
endef
define Package/libopenssl-afalg
$(call Package/openssl/Default)
SUBMENU:=SSL
TITLE:=AFALG hardware acceleration engine
- DEPENDS:=libopenssl @OPENSSL_ENGINE @KERNEL_AIO @!LINUX_3_18 +kmod-crypto-user
+ DEPENDS:=libopenssl @OPENSSL_ENGINE @KERNEL_AIO @!LINUX_3_18 +kmod-crypto-user \
+ +libopenssl-conf
endef
define Package/libopenssl-afalg/description
@@ -136,7 +149,8 @@ define Package/libopenssl-padlock
$(call Package/openssl/Default)
SUBMENU:=SSL
TITLE:=VIA Padlock hardware acceleration engine
- DEPENDS:=libopenssl @OPENSSL_ENGINE @TARGET_x86 +kmod-crypto-hw-padlock
+ DEPENDS:=libopenssl @OPENSSL_ENGINE @TARGET_x86 +kmod-crypto-hw-padlock \
+ +libopenssl-conf
endef
define Package/libopenssl-padlock/description
@@ -335,9 +349,12 @@ define Package/libopenssl/install
$(if $(CONFIG_OPENSSL_ENGINE),$(INSTALL_DIR) $(1)/usr/lib/$(ENGINES_DIR))
endef
-define Package/openssl-util/install
+define Package/libopenssl-conf/install
$(INSTALL_DIR) $(1)/etc/ssl
$(CP) $(PKG_INSTALL_DIR)/etc/ssl/openssl.cnf $(1)/etc/ssl/
+endef
+
+define Package/openssl-util/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
endef
@@ -353,6 +370,7 @@ define Package/libopenssl-padlock/install
endef
$(eval $(call BuildPackage,libopenssl))
+$(eval $(call BuildPackage,libopenssl-conf))
$(eval $(call BuildPackage,libopenssl-afalg))
$(eval $(call BuildPackage,libopenssl-padlock))
$(eval $(call BuildPackage,openssl-util))