aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/ncurses
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2014-11-06 19:35:23 +0000
committerNicolas Thill <nico@openwrt.org>2014-11-06 19:35:23 +0000
commitbd92e9806b35a0d9f6d8351eb274d2cdfcc142b9 (patch)
tree0807ce0b8e2b53553c8fdb390fd8641ad2dc9d2f /package/libs/ncurses
parent8d515b3b406af7af641cdde5d16da1ce8d869708 (diff)
downloadupstream-bd92e9806b35a0d9f6d8351eb274d2cdfcc142b9.tar.gz
upstream-bd92e9806b35a0d9f6d8351eb274d2cdfcc142b9.tar.bz2
upstream-bd92e9806b35a0d9f6d8351eb274d2cdfcc142b9.zip
ncurses: cleanup InstallDev
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 43204
Diffstat (limited to 'package/libs/ncurses')
-rw-r--r--package/libs/ncurses/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/libs/ncurses/Makefile b/package/libs/ncurses/Makefile
index b8088b9622..5d6e8fe2ab 100644
--- a/package/libs/ncurses/Makefile
+++ b/package/libs/ncurses/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -131,7 +131,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw5-config $(2)/bin/
$(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \
$(2)/bin/ncursesw5-config
- ln -sf $(STAGING_DIR)/host/bin/ncursesw5-config $(1)/usr/bin/ncursesw5-config
+ $(LN) $(2)/bin/ncursesw5-config $(1)/usr/bin/ncursesw5-config
endef
else
define Build/InstallDev
@@ -145,7 +145,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ncurses5-config $(2)/bin/
$(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
$(2)/bin/ncurses5-config
- ln -sf $(STAGING_DIR)/host/bin/ncurses5-config $(1)/usr/bin/ncurses5-config
+ $(LN) $(2)/bin/ncurses5-config $(1)/usr/bin/ncurses5-config
endef
endif