aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/ncurses
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-11 15:06:01 +0000
committerJohn Crispin <john@openwrt.org>2015-12-11 15:06:01 +0000
commit354aa80ada3ac1c39e3d752ecad9f90e4b80934b (patch)
treefab4bcb414bb19a07c156d5e87a9f18dc9870436 /package/libs/ncurses
parentf03bf608b15125049fe5b9e9b79db1a9d0750182 (diff)
downloadupstream-354aa80ada3ac1c39e3d752ecad9f90e4b80934b.tar.gz
upstream-354aa80ada3ac1c39e3d752ecad9f90e4b80934b.tar.bz2
upstream-354aa80ada3ac1c39e3d752ecad9f90e4b80934b.zip
ncurses: Fix build of libncursew
Packages using libncursesw can fail to build if both libncurses and libncursesw are not installed. Currently the ncurses.h file is installed in "usr/include/ncursesw" directory and includes other .h files in the "usr/include" directory incorrectly. For example: Including <ncursesw/ncurses.h> fails due to these references. These build changes will set the correct include paths within the developer includes. Packages that expect ncurses.h (or curses.h) in the default "usr/include" path fail even when expecting to build with libncursesw and will need to be fixed as well. However, they cannot be fixed until this patch is applied. Signed-off-by: Ted Hess <thess@kitschensync.net> SVN-Revision: 47853
Diffstat (limited to 'package/libs/ncurses')
-rw-r--r--package/libs/ncurses/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/libs/ncurses/Makefile b/package/libs/ncurses/Makefile
index 1f7ea9b1b0..924033fd1a 100644
--- a/package/libs/ncurses/Makefile
+++ b/package/libs/ncurses/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ncurses
PKG_VERSION:=5.9
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -91,6 +91,7 @@ endif
ifeq ($(BUILD_VARIANT),libncursesw)
CONFIGURE_ARGS += \
--enable-widec \
+ --includedir="/usr/include/ncursesw" \
--with-build-cppflags=-D_GNU_SOURCE
endif
@@ -138,7 +139,7 @@ endef
ifeq ($(BUILD_VARIANT),libncursesw)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/ncursesw/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/ncursesw/
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/ncursesw/*.h $(1)/usr/include/ncursesw/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ncurses,panel,menu,form}w.{a,so*} $(1)/usr/lib/