aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/musl-fts
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-08-13 11:43:18 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-08-13 11:44:05 +0100
commitab4c6f1632f0691da969e2e42e14719716c90485 (patch)
tree2a74b25db507c211df29397bb7345f2f6f88fa07 /package/libs/musl-fts
parente16b84df15c1eac7b389fb715c9d00969acf3b30 (diff)
downloadupstream-ab4c6f1632f0691da969e2e42e14719716c90485.tar.gz
upstream-ab4c6f1632f0691da969e2e42e14719716c90485.tar.bz2
upstream-ab4c6f1632f0691da969e2e42e14719716c90485.zip
musl-fts: import from packages feed
libselinux requires musl-fts to build with musl. Import it from packages feed as well. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/libs/musl-fts')
-rw-r--r--package/libs/musl-fts/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/package/libs/musl-fts/Makefile b/package/libs/musl-fts/Makefile
new file mode 100644
index 0000000000..494f700f8a
--- /dev/null
+++ b/package/libs/musl-fts/Makefile
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2017 Lucian Cristian <lucian.cristian@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# updated to work with latest source from abrasive
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=musl-fts
+PKG_VERSION:=1.2.7
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/pullmoll/musl-fts.git
+PKG_SOURCE_VERSION:=0bde52df588e8969879a2cae51c3a4774ec62472
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MIRROR_HASH:=29c62a600128e9189b1b2e1aea568546178eedf739527f657873b3b773072ecb
+
+PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
+
+PKG_LICENSE:=LGPL-2.1
+PKG_LICENSE_FILES:=COPYING AUTHORS
+
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=autogen.sh
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/musl-fts
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=fts implementation for musl libc
+ URL:=https://github.com/pullmoll/musl-fts
+ DEPENDS:= +libpthread
+endef
+
+define Package/musl-fts/description
+ The musl-fts package implements the fts(3) functions fts_open, fts_read, fts_children, fts_set and fts_close, which are missing in musl libc.
+endef
+
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/fts.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfts.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/musl-fts.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/musl-fts/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfts.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,musl-fts))