aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/mbedtls
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2018-07-27 12:16:29 +0200
committerJohn Crispin <john@phrozen.org>2018-07-30 10:35:12 +0200
commit5b614e33476269ccb7b526e9e7e5f67eacdb9dc1 (patch)
tree7c987fab18da5d30a6965b265a8081614a26cd8e /package/libs/mbedtls
parenta93b6edfec1482b58be4623d999ca69458d432ea (diff)
downloadupstream-5b614e33476269ccb7b526e9e7e5f67eacdb9dc1.tar.gz
upstream-5b614e33476269ccb7b526e9e7e5f67eacdb9dc1.tar.bz2
upstream-5b614e33476269ccb7b526e9e7e5f67eacdb9dc1.zip
mbedtls: Update to 2.12.0
Update mbedtls to 2.12.0 Multiple security fixes Add support for Chacha20 and Poly1305 cryptographic primitives and their associated ciphersuites Difference in size on mips_24kc (ipk): 164kbytes (167882 bytes) 170kbytes (173563 bytes) https://tls.mbed.org/tech-updates/releases/mbedtls-2.12.0-2.7.5-and-2.1.14-released Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'package/libs/mbedtls')
-rw-r--r--package/libs/mbedtls/Makefile4
-rw-r--r--package/libs/mbedtls/patches/200-config.patch52
2 files changed, 28 insertions, 28 deletions
diff --git a/package/libs/mbedtls/Makefile b/package/libs/mbedtls/Makefile
index 86df1154b4..659bf59d88 100644
--- a/package/libs/mbedtls/Makefile
+++ b/package/libs/mbedtls/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mbedtls
-PKG_VERSION:=2.11.0
+PKG_VERSION:=2.12.0
PKG_RELEASE:=1
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
PKG_SOURCE_URL:=https://tls.mbed.org/download/
-PKG_HASH:=47b57d472bb42929c1083eab7073e234fa5e37fca0706de53cd80ac71eb9aac6
+PKG_HASH:=8661d19a896a5a7a232ed01ac7f05cf0ec3514798f18076c2c9ef965fbeb5a28
PKG_BUILD_PARALLEL:=1
PKG_LICENSE:=GPL-2.0+
diff --git a/package/libs/mbedtls/patches/200-config.patch b/package/libs/mbedtls/patches/200-config.patch
index d925ee3750..bfadb8d3d2 100644
--- a/package/libs/mbedtls/patches/200-config.patch
+++ b/package/libs/mbedtls/patches/200-config.patch
@@ -1,6 +1,6 @@
--- a/include/mbedtls/config.h
+++ b/include/mbedtls/config.h
-@@ -522,14 +522,14 @@
+@@ -548,14 +548,14 @@
*
* Enable Output Feedback mode (OFB) for symmetric ciphers.
*/
@@ -17,7 +17,7 @@
/**
* \def MBEDTLS_CIPHER_NULL_CIPHER
-@@ -619,19 +619,19 @@
+@@ -645,19 +645,19 @@
*
* Comment macros to disable the curve and functions for it
*/
@@ -46,7 +46,7 @@
/**
* \def MBEDTLS_ECP_NIST_OPTIM
-@@ -709,7 +709,7 @@
+@@ -735,7 +735,7 @@
* See dhm.h for more details.
*
*/
@@ -55,7 +55,7 @@
/**
* \def MBEDTLS_KEY_EXCHANGE_ECDHE_PSK_ENABLED
-@@ -729,7 +729,7 @@
+@@ -755,7 +755,7 @@
* MBEDTLS_TLS_ECDHE_PSK_WITH_3DES_EDE_CBC_SHA
* MBEDTLS_TLS_ECDHE_PSK_WITH_RC4_128_SHA
*/
@@ -64,7 +64,7 @@
/**
* \def MBEDTLS_KEY_EXCHANGE_RSA_PSK_ENABLED
-@@ -754,7 +754,7 @@
+@@ -780,7 +780,7 @@
* MBEDTLS_TLS_RSA_PSK_WITH_3DES_EDE_CBC_SHA
* MBEDTLS_TLS_RSA_PSK_WITH_RC4_128_SHA
*/
@@ -73,7 +73,7 @@
/**
* \def MBEDTLS_KEY_EXCHANGE_RSA_ENABLED
-@@ -888,7 +888,7 @@
+@@ -914,7 +914,7 @@
* MBEDTLS_TLS_ECDH_ECDSA_WITH_CAMELLIA_128_GCM_SHA256
* MBEDTLS_TLS_ECDH_ECDSA_WITH_CAMELLIA_256_GCM_SHA384
*/
@@ -82,7 +82,7 @@
/**
* \def MBEDTLS_KEY_EXCHANGE_ECDH_RSA_ENABLED
-@@ -912,7 +912,7 @@
+@@ -938,7 +938,7 @@
* MBEDTLS_TLS_ECDH_RSA_WITH_CAMELLIA_128_GCM_SHA256
* MBEDTLS_TLS_ECDH_RSA_WITH_CAMELLIA_256_GCM_SHA384
*/
@@ -91,7 +91,7 @@
/**
* \def MBEDTLS_KEY_EXCHANGE_ECJPAKE_ENABLED
-@@ -1016,7 +1016,7 @@
+@@ -1042,7 +1042,7 @@
* This option is only useful if both MBEDTLS_SHA256_C and
* MBEDTLS_SHA512_C are defined. Otherwise the available hash module is used.
*/
@@ -100,7 +100,7 @@
/**
* \def MBEDTLS_ENTROPY_NV_SEED
-@@ -1111,14 +1111,14 @@
+@@ -1137,14 +1137,14 @@
* Uncomment this macro to disable the use of CRT in RSA.
*
*/
@@ -117,7 +117,7 @@
/**
* \def MBEDTLS_SHA256_SMALLER
-@@ -1272,7 +1272,7 @@
+@@ -1298,7 +1298,7 @@
* configuration of this extension).
*
*/
@@ -126,7 +126,7 @@
/**
* \def MBEDTLS_SSL_SRV_SUPPORT_SSLV2_CLIENT_HELLO
-@@ -1447,7 +1447,7 @@
+@@ -1473,7 +1473,7 @@
*
* Comment this macro to disable support for SSL session tickets
*/
@@ -135,7 +135,7 @@
/**
* \def MBEDTLS_SSL_EXPORT_KEYS
-@@ -1477,7 +1477,7 @@
+@@ -1503,7 +1503,7 @@
*
* Comment this macro to disable support for truncated HMAC in SSL
*/
@@ -144,7 +144,7 @@
/**
* \def MBEDTLS_SSL_TRUNCATED_HMAC_COMPAT
-@@ -1536,7 +1536,7 @@
+@@ -1562,7 +1562,7 @@
*
* Comment this to disable run-time checking and save ROM space
*/
@@ -153,7 +153,7 @@
/**
* \def MBEDTLS_X509_ALLOW_EXTENSIONS_NON_V3
-@@ -1866,7 +1866,7 @@
+@@ -1892,7 +1892,7 @@
* MBEDTLS_TLS_PSK_WITH_CAMELLIA_128_GCM_SHA256
* MBEDTLS_TLS_PSK_WITH_CAMELLIA_128_CBC_SHA256
*/
@@ -162,7 +162,7 @@
/**
* \def MBEDTLS_ARIA_C
-@@ -1932,7 +1932,7 @@
+@@ -1958,7 +1958,7 @@
* This module enables the AES-CCM ciphersuites, if other requisites are
* enabled as well.
*/
@@ -171,7 +171,7 @@
/**
* \def MBEDTLS_CERTS_C
-@@ -1944,7 +1944,7 @@
+@@ -1970,7 +1970,7 @@
*
* This module is used for testing (ssl_client/server).
*/
@@ -179,8 +179,8 @@
+//#define MBEDTLS_CERTS_C
/**
- * \def MBEDTLS_CIPHER_C
-@@ -1997,7 +1997,7 @@
+ * \def MBEDTLS_CHACHA20_C
+@@ -2043,7 +2043,7 @@
*
* This module provides debugging functions.
*/
@@ -189,7 +189,7 @@
/**
* \def MBEDTLS_DES_C
-@@ -2026,7 +2026,7 @@
+@@ -2072,7 +2072,7 @@
* \warning DES is considered a weak cipher and its use constitutes a
* security risk. We recommend considering stronger ciphers instead.
*/
@@ -198,7 +198,7 @@
/**
* \def MBEDTLS_DHM_C
-@@ -2189,7 +2189,7 @@
+@@ -2235,7 +2235,7 @@
* This module adds support for the Hashed Message Authentication Code
* (HMAC)-based key derivation function (HKDF).
*/
@@ -207,7 +207,7 @@
/**
* \def MBEDTLS_HMAC_DRBG_C
-@@ -2486,7 +2486,7 @@
+@@ -2545,7 +2545,7 @@
*
* This module enables abstraction of common (libc) functions.
*/
@@ -215,8 +215,8 @@
+//#define MBEDTLS_PLATFORM_C
/**
- * \def MBEDTLS_RIPEMD160_C
-@@ -2497,7 +2497,7 @@
+ * \def MBEDTLS_POLY1305_C
+@@ -2566,7 +2566,7 @@
* Caller: library/md.c
*
*/
@@ -225,7 +225,7 @@
/**
* \def MBEDTLS_RSA_C
-@@ -2604,7 +2604,7 @@
+@@ -2673,7 +2673,7 @@
*
* Requires: MBEDTLS_CIPHER_C
*/
@@ -234,7 +234,7 @@
/**
* \def MBEDTLS_SSL_CLI_C
-@@ -2704,7 +2704,7 @@
+@@ -2773,7 +2773,7 @@
*
* This module provides run-time version information.
*/
@@ -243,7 +243,7 @@
/**
* \def MBEDTLS_X509_USE_C
-@@ -2814,7 +2814,7 @@
+@@ -2883,7 +2883,7 @@
* Module: library/xtea.c
* Caller:
*/