aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/mbedtls
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2018-06-11 00:22:36 +0200
committerJohn Crispin <john@phrozen.org>2018-06-18 20:28:20 +0200
commit5297a759aee34952299d1d42f677f31781026c67 (patch)
treeca84eacde157fb0a1f3b6cdb3a0f6f5dcec5a133 /package/libs/mbedtls
parente820455198aa50cc32f9a108a4696f0cc23023c3 (diff)
downloadupstream-5297a759aee34952299d1d42f677f31781026c67.tar.gz
upstream-5297a759aee34952299d1d42f677f31781026c67.tar.bz2
upstream-5297a759aee34952299d1d42f677f31781026c67.zip
mbedtls: Cosmetic cleanups
This is more of a cosmetic change and a reminder that the CMake script hardcodes -O2. Source: https://github.com/ARMmbed/mbedtls/blob/mbedtls-2.7/CMakeLists.txt#L73 https://github.com/ARMmbed/mbedtls/blob/master/CMakeLists.txt#L97 Remove the release type option as it's already provided by the toolchain. Source: https://github.com/openwrt/openwrt/blob/master/include/cmake.mk#L50 Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'package/libs/mbedtls')
-rw-r--r--package/libs/mbedtls/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/mbedtls/Makefile b/package/libs/mbedtls/Makefile
index 8e0a480e40..19db4b803b 100644
--- a/package/libs/mbedtls/Makefile
+++ b/package/libs/mbedtls/Makefile
@@ -64,9 +64,9 @@ endef
PKG_INSTALL:=1
TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_CFLAGS := $(filter-out -O%,$(TARGET_CFLAGS))
CMAKE_OPTIONS += \
- -DCMAKE_BUILD_TYPE:String="Release" \
-DUSE_SHARED_MBEDTLS_LIBRARY:Bool=ON \
-DENABLE_TESTING:Bool=OFF \
-DENABLE_PROGRAMS:Bool=ON