aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libusb
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-22 19:17:32 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-24 10:39:30 +0100
commit0e70f69a35fd79be781c859c12487b626e243e96 (patch)
tree2025021f55f831e09f0f102969e01532881b8147 /package/libs/libusb
parent60558790a2a832265ec041131e851b6648f514d4 (diff)
downloadupstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.gz
upstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.bz2
upstream-0e70f69a35fd79be781c859c12487b626e243e96.zip
treewide: revise library packaging
- Annotate versionless libraries (such as libubox, libuci etc.) with a fixed ABI_VERSION resembling the source date of the last incompatible change - Annotate packages shipping versioned library objects with ABI_VERSION - Stop shipping unversioned library symlinks for packages with ABI_VERSION Ref: https://openwrt.org/docs/guide-developer/package-policies#shared_libraries Ref: https://github.com/KanjiMonster/maintainer-tools/blob/master/check-abi-versions.pl Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/libs/libusb')
-rw-r--r--package/libs/libusb/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/libs/libusb/Makefile b/package/libs/libusb/Makefile
index 54008212b9..6ce33d3f86 100644
--- a/package/libs/libusb/Makefile
+++ b/package/libs/libusb/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libusb
PKG_VERSION:=1.0.22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=\
@@ -31,6 +31,7 @@ define Package/libusb-1.0
TITLE:=A library for accessing Linux USB devices
DEPENDS:=+libpthread +librt
URL:=http://libusb.info/
+ ABI_VERSION:=0
endef
define Package/libusb-1.0/description
@@ -49,7 +50,7 @@ endef
define Package/libusb-1.0/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb*.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libusb-1.0))