aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libusb/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-29 10:48:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-29 10:48:37 +0000
commit5fdc8ca9b8d1bb652ad442a9c1835a1c984a8306 (patch)
treea6a47736669714c32749b20daa7d38f5e7b4b560 /package/libs/libusb/Makefile
parent78a64397842623354b9764582fb7726fc8b13910 (diff)
downloadupstream-5fdc8ca9b8d1bb652ad442a9c1835a1c984a8306.tar.gz
upstream-5fdc8ca9b8d1bb652ad442a9c1835a1c984a8306.tar.bz2
upstream-5fdc8ca9b8d1bb652ad442a9c1835a1c984a8306.zip
libusb: add from /packages, add myself as maintainer
SVN-Revision: 35373
Diffstat (limited to 'package/libs/libusb/Makefile')
-rw-r--r--package/libs/libusb/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/package/libs/libusb/Makefile b/package/libs/libusb/Makefile
new file mode 100644
index 0000000000..d1bdb010f3
--- /dev/null
+++ b/package/libs/libusb/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libusb
+PKG_VERSION:=1.0.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=7f5a02375ad960d4e33a6dae7d63cfcb
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+PKG_MAINTAINER := Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libusb-1.0
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A library for accessing Linux USB devices
+ DEPENDS:=+libpthread +librt
+ URL:=http://libusb.wiki.sourceforge.net/
+endef
+
+define Package/libusb-1.0/description
+ libusb is a C library that gives applications easy access to USB devices on
+ many different operating systems.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libusb-1.0/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb*.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libusb-1.0))