aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libusb/Makefile
diff options
context:
space:
mode:
authorGeorgi Valkov <gvalkov@abv.bg>2021-02-03 09:41:54 +0200
committerPaul Spooren <mail@aparcar.org>2021-02-21 10:12:10 -1000
commit4b37e3bc2b2a079c996b6d97b8d3dbbd4ba6eb62 (patch)
treec1acb0340f235878f57cb33d5b85bb471d2f7465 /package/libs/libusb/Makefile
parentd3140d05296461deddaaa8ca2ce4a4a97a320eff (diff)
downloadupstream-4b37e3bc2b2a079c996b6d97b8d3dbbd4ba6eb62.tar.gz
upstream-4b37e3bc2b2a079c996b6d97b8d3dbbd4ba6eb62.tar.bz2
upstream-4b37e3bc2b2a079c996b6d97b8d3dbbd4ba6eb62.zip
libusb: Fix parsing of descriptors for multi-configuration devices
Prerequisite patch: Correct a typo in the Changelog and clean up a stray file Fix changes in libusb which introduced a regression: Commit e2be556bd2 ("linux_usbfs: Parse config descriptors during device initialization") introduced a regression for devices with multiple configurations. The logic that verifies the reported length of the configuration descriptors failed to count the length of the configuration descriptor itself and would truncate the actual length by 9 bytes, leading to a parsing error for subsequent descriptors. Signed-off-by: Georgi Valkov <gvalkov@abv.bg>
Diffstat (limited to 'package/libs/libusb/Makefile')
-rw-r--r--package/libs/libusb/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/libusb/Makefile b/package/libs/libusb/Makefile
index e931536339..6b80b3848d 100644
--- a/package/libs/libusb/Makefile
+++ b/package/libs/libusb/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libusb
PKG_VERSION:=1.0.24
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=\