aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libunwind
diff options
context:
space:
mode:
authorDonald Hoskins <grommish@gmail.com>2021-02-14 15:35:45 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-01 00:34:23 +0100
commitea6d4bdde20a3fecbfc44b99f53373e1d0666e34 (patch)
tree360d7436fcc0a27606f367dad11fc374ca3e3972 /package/libs/libunwind
parent3cc57ba4627c9c7555f8ad86e4f78d86d8f9ddf0 (diff)
downloadupstream-ea6d4bdde20a3fecbfc44b99f53373e1d0666e34.tar.gz
upstream-ea6d4bdde20a3fecbfc44b99f53373e1d0666e34.tar.bz2
upstream-ea6d4bdde20a3fecbfc44b99f53373e1d0666e34.zip
libunwind: Add MIPS64 dep check
libunwind dependency check does not allow for MIPS64 arch. Add MIPS64 awareness. libunwind seems to support MIPS64 without issues, it was limited by the dep arch check in the Makefile. Used to compile Suricata6/Rust locally without issue. Signed-off-by: Donald Hoskins <grommish@gmail.com>
Diffstat (limited to 'package/libs/libunwind')
-rw-r--r--package/libs/libunwind/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/libunwind/Makefile b/package/libs/libunwind/Makefile
index 89e6f84ff5..7f79996d25 100644
--- a/package/libs/libunwind/Makefile
+++ b/package/libs/libunwind/Makefile
@@ -32,7 +32,7 @@ define Package/libunwind
CATEGORY:=Libraries
TITLE:=The libunwind project
URL:=http://www.nongnu.org/libunwind/
- DEPENDS:=@((mips||mipsel||x86_64||arm||aarch64)||(USE_GLIBC&&(powerpc||i386))) +zlib
+ DEPENDS:=@((mips||mipsel||mips64||x86_64||arm||aarch64)||(USE_GLIBC&&(powerpc||i386))) +zlib
ABI_VERSION:=8
endef