aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libunwind/patches
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-05-22 10:35:10 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-05-22 11:07:40 +0800
commit5d48dc1146171520445c43ee894d9dfce09ae4e2 (patch)
tree359d47d2769dd4bc5426d283a0f3cb021ebb5227 /package/libs/libunwind/patches
parent6e10fc74fd569b71b6f64f5a2420dc624d73bee2 (diff)
downloadupstream-5d48dc1146171520445c43ee894d9dfce09ae4e2.tar.gz
upstream-5d48dc1146171520445c43ee894d9dfce09ae4e2.tar.bz2
upstream-5d48dc1146171520445c43ee894d9dfce09ae4e2.zip
libunwind: update to 1.2
Addresses CVE-2015-3239: Off-by-one error in the dwarf_to_unw_regnum function in include/dwarf_i.h in libunwind 1.1 allows local users to have unspecified impact via invalid dwarf opcodes. Upstream stable-v1.2 fixed the missing unwind_i.h issue but no new tarball is released yet Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/libs/libunwind/patches')
-rw-r--r--package/libs/libunwind/patches/001-disable-tests.patch21
-rw-r--r--package/libs/libunwind/patches/004-add-missing-unwind_i.h.patch46
2 files changed, 51 insertions, 16 deletions
diff --git a/package/libs/libunwind/patches/001-disable-tests.patch b/package/libs/libunwind/patches/001-disable-tests.patch
index 9700fea477..667b6a71e2 100644
--- a/package/libs/libunwind/patches/001-disable-tests.patch
+++ b/package/libs/libunwind/patches/001-disable-tests.patch
@@ -1,22 +1,11 @@
--- a/Makefile.am
+++ b/Makefile.am
-@@ -36,7 +36,7 @@
+@@ -42,7 +42,7 @@ endif
nodist_include_HEADERS = include/libunwind-common.h
--SUBDIRS = src tests doc
-+SUBDIRS = src doc
+-SUBDIRS = src tests
++SUBDIRS = src
- noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
- include/compiler.h include/libunwind_i.h include/mempool.h \
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -313,7 +313,7 @@
- $(am__append_7) $(am__append_8) $(am__append_9) \
- $(am__append_10)
- nodist_include_HEADERS = include/libunwind-common.h
--SUBDIRS = src tests doc
-+SUBDIRS = src doc
- noinst_HEADERS = include/dwarf.h include/dwarf_i.h include/dwarf-eh.h \
- include/compiler.h include/libunwind_i.h include/mempool.h \
- include/remote.h \
+ if CONFIG_DOCS
+ SUBDIRS += doc
diff --git a/package/libs/libunwind/patches/004-add-missing-unwind_i.h.patch b/package/libs/libunwind/patches/004-add-missing-unwind_i.h.patch
new file mode 100644
index 0000000000..55a68494cc
--- /dev/null
+++ b/package/libs/libunwind/patches/004-add-missing-unwind_i.h.patch
@@ -0,0 +1,46 @@
+--- /dev/null 2017-05-16 16:52:50.220000000 +0800
++++ b/src/mips/unwind_i.h 2016-06-13 11:43:06.310153501 +0800
+@@ -0,0 +1,43 @@
++/* libunwind - a platform-independent unwind library
++ Copyright (C) 2008 CodeSourcery
++
++This file is part of libunwind.
++
++Permission is hereby granted, free of charge, to any person obtaining
++a copy of this software and associated documentation files (the
++"Software"), to deal in the Software without restriction, including
++without limitation the rights to use, copy, modify, merge, publish,
++distribute, sublicense, and/or sell copies of the Software, and to
++permit persons to whom the Software is furnished to do so, subject to
++the following conditions:
++
++The above copyright notice and this permission notice shall be
++included in all copies or substantial portions of the Software.
++
++THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
++MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
++LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
++OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
++WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. */
++
++#ifndef unwind_i_h
++#define unwind_i_h
++
++#include <stdint.h>
++
++#include <libunwind-mips.h>
++
++#include "libunwind_i.h"
++
++#define mips_lock UNW_OBJ(lock)
++#define mips_local_resume UNW_OBJ(local_resume)
++#define mips_local_addr_space_init UNW_OBJ(local_addr_space_init)
++
++extern int mips_local_resume (unw_addr_space_t as, unw_cursor_t *cursor,
++ void *arg);
++
++extern void mips_local_addr_space_init (void);
++
++#endif /* unwind_i_h */