aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libubox
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-02-15 00:13:07 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-02-15 01:15:49 +0100
commit505a808302f0a7bf8a0da77981532d7274360edd (patch)
tree0f7b5a5a85011b035f64198b02c83718cabf94cc /package/libs/libubox
parent539966554d6d0686dc8ce62e39ff9e8f4e2d4e74 (diff)
downloadupstream-505a808302f0a7bf8a0da77981532d7274360edd.tar.gz
upstream-505a808302f0a7bf8a0da77981532d7274360edd.tar.bz2
upstream-505a808302f0a7bf8a0da77981532d7274360edd.zip
Revert "libubox: use PKG_ABI_VERSION"
This fixes the build on MIPS BE like ath25 and ath79 target. We get this error message when linking libubox: mips-openwrt-linux-musl/bin/ld: /home/hauke/openwrt/openwrt/staging_dir/target-mips_mips32_musl/usr/lib/libubox.so: unknown type [0x7000002a] section `.MIPS.abiflags' mips-openwrt-linux-musl/bin/ld: /home/hauke/openwrt/openwrt/staging_dir/target-mips_mips32_musl/usr/lib/libubox.so: unknown type [0x7000002a] section `.MIPS.abiflags' mips-openwrt-linux-musl/bin/ld: skipping incompatible /home/hauke/openwrt/openwrt/staging_dir/target-mips_mips32_musl/usr/lib/libubox.so when searching for -lubox This reverts commit f421fefa8a34319c5ff5dcc1af39d6311ec1ad1e. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/libs/libubox')
-rw-r--r--package/libs/libubox/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/libs/libubox/Makefile b/package/libs/libubox/Makefile
index 19d9145509..d9c239a50d 100644
--- a/package/libs/libubox/Makefile
+++ b/package/libs/libubox/Makefile
@@ -8,7 +8,6 @@ PKG_SOURCE_URL=$(PROJECT_GIT)/project/libubox.git
PKG_MIRROR_HASH:=97dc4eba01cf2c5d6a6d0db3747e0cdc0d95cb87e51b3115272e7d3e69a8b255
PKG_SOURCE_DATE:=2020-12-12
PKG_SOURCE_VERSION:=357877693ca363b12e6e7e14d345639b2440cd07
-PKG_ABI_VERSION:=$(call abi_version_str,$(PKG_SOURCE_DATE))
CMAKE_INSTALL:=1
PKG_LICENSE:=ISC
@@ -28,7 +27,7 @@ define Package/libubox
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Basic utility library
- ABI_VERSION:=$(PKG_ABI_VERSION)
+ ABI_VERSION:=20201212
DEPENDS:=
endef
@@ -36,7 +35,6 @@ define Package/libblobmsg-json
SECTION:=libs
CATEGORY:=Libraries
TITLE:=blobmsg <-> json conversion library
- ABI_VERSION:=$(PKG_ABI_VERSION)
DEPENDS:=+libjson-c +libubox
endef
@@ -55,7 +53,6 @@ define Package/libjson-script
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+libubox
- ABI_VERSION:=$(PKG_ABI_VERSION)
TITLE:=Minimalistic JSON based scripting engine
endef