aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libsepol
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2020-08-11 09:43:51 -0500
committerDaniel Golle <daniel@makrotopia.org>2020-08-13 09:31:34 +0100
commit6531eee347709a4b5f2e74cca8f907c2ec18321f (patch)
tree737cd594d005054ed83fe3ee86f97aec8fcfcb59 /package/libs/libsepol
parent2d9db93397f3120591bab0cf89347eec55c168f3 (diff)
downloadupstream-6531eee347709a4b5f2e74cca8f907c2ec18321f.tar.gz
upstream-6531eee347709a4b5f2e74cca8f907c2ec18321f.tar.bz2
upstream-6531eee347709a4b5f2e74cca8f907c2ec18321f.zip
libsepol: add new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> [rebase, update to 3.1] Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'package/libs/libsepol')
-rw-r--r--package/libs/libsepol/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/package/libs/libsepol/Makefile b/package/libs/libsepol/Makefile
new file mode 100644
index 0000000000..cd49ed008d
--- /dev/null
+++ b/package/libs/libsepol/Makefile
@@ -0,0 +1,66 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libsepol
+PKG_VERSION:=3.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
+PKG_HASH:=ae6778d01443fdd38cd30eeee846494e19f4d407b09872580372f4aa4bf8a3cc
+
+PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libsepol
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=SELinux binary policy manipulation library
+ URL:=http://selinuxproject.org/page/Main_Page
+endef
+
+define Package/libsepol/description
+ Libsepol is the binary policy manipulation library. It doesn't
+ depend upon or use any of the other SELinux components.
+endef #'
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_MAKE_FLAGS += \
+ PREFIX=$(STAGING_DIR_HOSTPKG) \
+ SHLIBDIR=$(STAGING_DIR_HOSTPKG)/lib
+
+MAKE_FLAGS += \
+ SHLIBDIR=/usr/lib
+
+define Build/Compile
+ $(call Build/Compile/Default,all)
+endef
+
+define Build/Install
+ $(call Build/Install/Default,install)
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libsepol.pc $(1)/usr/lib/pkgconfig/
+ $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libsepol.pc
+ $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/libsepol.pc
+endef
+
+define Package/libsepol/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsepol.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call HostBuild))
+$(eval $(call BuildPackage,libsepol))