aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libsemanage
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-08-31 13:37:08 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-08-31 13:52:05 +0100
commite8688098616edb64b0e75dc53e2dbe24c985c1ca (patch)
treee0a69abdc3962215775b734efd49ec6c05881cea /package/libs/libsemanage
parent73912b850b7dc111ff54cd2bf5567a39000c6e8c (diff)
downloadupstream-e8688098616edb64b0e75dc53e2dbe24c985c1ca.tar.gz
upstream-e8688098616edb64b0e75dc53e2dbe24c985c1ca.tar.bz2
upstream-e8688098616edb64b0e75dc53e2dbe24c985c1ca.zip
libsemanage: new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> [update to 3.1] Signed-off-by: W. Michael Petullo <mike@flyn.org> [removed python part for inclusion in core] Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/libs/libsemanage')
-rw-r--r--package/libs/libsemanage/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/package/libs/libsemanage/Makefile b/package/libs/libsemanage/Makefile
new file mode 100644
index 0000000000..8448ad967f
--- /dev/null
+++ b/package/libs/libsemanage/Makefile
@@ -0,0 +1,66 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libsemanage
+PKG_VERSION:=3.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
+PKG_HASH:=22d6c75526e40d1781c30bcf29abf97171bdfe6780923f11c8e1c76a75a21ff8
+HOST_BUILD_DEPENDS:=audit/host libselinux/host bzip2/host
+
+PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+PKG_INSTALL:=1
+
+define Package/libsemanage
+ SECTION:=libs
+ DEPENDS:=+libaudit +libselinux +libbz2
+ CATEGORY:=Libraries
+ TITLE:=SELinux policy management library
+ URL:=http://selinuxproject.org/page/Main_Page
+endef
+
+define Package/libsemanage/description
+ libsemanage is the policy management library. It uses
+ libsepol for binary policy manipulation and libselinux for
+ interacting with the SELinux system. It also exec's helper
+ programs for loading policy and for checking whether the
+ file_contexts configuration is valid (load_policy and
+ setfiles from policycoreutils) presently, although this may
+ change at least for the bootstrapping case (for rpm).
+endef #'
+
+
+HOST_MAKE_FLAGS += \
+ DESTDIR=$(STAGING_DIR_HOSTPKG) \
+ PREFIX=""
+
+
+define Build/Configure
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libsemanage.pc $(1)/usr/lib/pkgconfig/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+endef
+
+define Package/libsemanage/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsemanage.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call HostBuild))
+$(eval $(call BuildPackage,libsemanage))