aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libnl-tiny
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-11 19:35:48 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-11 19:35:48 +0000
commite983ee54fd56379d8dcf19ec6dddad41c2784825 (patch)
tree8d051e3370ef2278e77f228882af22f9e953fa2f /package/libs/libnl-tiny
parentb7b52ce7def719a6296b32b92f2e0d2d0d950672 (diff)
downloadupstream-e983ee54fd56379d8dcf19ec6dddad41c2784825.tar.gz
upstream-e983ee54fd56379d8dcf19ec6dddad41c2784825.tar.bz2
upstream-e983ee54fd56379d8dcf19ec6dddad41c2784825.zip
libnl-tiny: fix receiving netlink messages larger than 4K
Apply libnl commit 807fddc4cd9ecb12ba64e1b7fa26d86b6c2f19b0 ("nl: Increase receive buffer size to 4 pages") also to libnl-tiny to ensure netlink messages larger than 4KiB can be received, as the restart logic seems to be broken. This fixes iwinfo accessing info on dual band b43 cards, as they can support a lot of channels, breaking the 4K default limit (seen was >5k). Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 43633
Diffstat (limited to 'package/libs/libnl-tiny')
-rw-r--r--package/libs/libnl-tiny/Makefile2
-rw-r--r--package/libs/libnl-tiny/src/nl.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/libs/libnl-tiny/Makefile b/package/libs/libnl-tiny/Makefile
index b3957b0b14..2445ad440b 100644
--- a/package/libs/libnl-tiny/Makefile
+++ b/package/libs/libnl-tiny/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libnl-tiny
PKG_VERSION:=0.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=LGPL-2.1
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
diff --git a/package/libs/libnl-tiny/src/nl.c b/package/libs/libnl-tiny/src/nl.c
index 99e9aebeba..ea7d96898b 100644
--- a/package/libs/libnl-tiny/src/nl.c
+++ b/package/libs/libnl-tiny/src/nl.c
@@ -397,7 +397,7 @@ int nl_recv(struct nl_sock *sk, struct sockaddr_nl *nla,
flags |= MSG_PEEK;
if (page_size == 0)
- page_size = getpagesize();
+ page_size = getpagesize() * 4;
iov.iov_len = page_size;
iov.iov_base = *buf = malloc(iov.iov_len);