aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libnetfilter-queue
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-10-08 21:46:44 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2017-10-09 16:06:06 +0300
commitbcfc39b763e8f748aa0383711691492430ef6e65 (patch)
tree7c0619e528c9264d6074bc67c4632d24d451dfa4 /package/libs/libnetfilter-queue
parentc972779e9875a3b69ae607bdb691bf5ff52710cf (diff)
downloadupstream-bcfc39b763e8f748aa0383711691492430ef6e65.tar.gz
upstream-bcfc39b763e8f748aa0383711691492430ef6e65.tar.bz2
upstream-bcfc39b763e8f748aa0383711691492430ef6e65.zip
libnetfilter_queue: bump to git HEAD
b39cac7 src: Correct typo in the location of internal.h in #include 58cb066 src: Declare the define visibility attribute together e84b559 Revert "src: Declare the define visibility attribute together" 003c2b1 examples: set dummy connmark value to show use of NFQA_CT nested attribute 63973da doc: extend the doxygen section about NFQA_CFG_F_GSO d7f74c7 build: bump version to 1.0.3 3f9eb57 build: bump library release version too 601abd1 doc: Add information about retrieving UID/GID/SECCTX fields Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/libs/libnetfilter-queue')
-rw-r--r--package/libs/libnetfilter-queue/Makefile6
-rw-r--r--package/libs/libnetfilter-queue/patches/100-checksum_computation.patch18
2 files changed, 11 insertions, 13 deletions
diff --git a/package/libs/libnetfilter-queue/Makefile b/package/libs/libnetfilter-queue/Makefile
index 3bbc2d14f3..8a11d07988 100644
--- a/package/libs/libnetfilter-queue/Makefile
+++ b/package/libs/libnetfilter-queue/Makefile
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=https://git.netfilter.org/libnetfilter_queue
-PKG_SOURCE_DATE:=2016-07-03
-PKG_SOURCE_VERSION:=981025e103d887fb6a9c9bb49c74ec323108d098
-PKG_MIRROR_HASH:=85c124be0e19162e1ebd1aba6e7e86bb4106e9dab4267baaf66d3ccb48d56e3f
+PKG_SOURCE_DATE:=2017-06-27
+PKG_SOURCE_VERSION:=601abd1c71ccdf90753cf294c120ad43fb25dc54
+PKG_MIRROR_HASH:=283b99cfe5856dc87fd6bab8f78c0c59b72462d6b4f2b13111f928cf33020eb3
PKG_FIXUP:=autoreconf
PKG_LICENSE:=GPL-2.0+
diff --git a/package/libs/libnetfilter-queue/patches/100-checksum_computation.patch b/package/libs/libnetfilter-queue/patches/100-checksum_computation.patch
index 81faffe82e..92e750d510 100644
--- a/package/libs/libnetfilter-queue/patches/100-checksum_computation.patch
+++ b/package/libs/libnetfilter-queue/patches/100-checksum_computation.patch
@@ -8,7 +8,7 @@
#include <arpa/inet.h>
#include <netinet/ip.h>
#include <netinet/ip6.h>
-@@ -26,8 +27,13 @@ uint16_t nfq_checksum(uint32_t sum, uint16_t *buf, int size)
+@@ -26,8 +27,13 @@ uint16_t nfq_checksum(uint32_t sum, uint
sum += *buf++;
size -= sizeof(uint16_t);
}
@@ -24,7 +24,7 @@
sum = (sum >> 16) + (sum & 0xffff);
sum += (sum >>16);
-@@ -35,7 +41,7 @@ uint16_t nfq_checksum(uint32_t sum, uint16_t *buf, int size)
+@@ -35,7 +41,7 @@ uint16_t nfq_checksum(uint32_t sum, uint
return (uint16_t)(~sum);
}
@@ -33,7 +33,7 @@
{
uint32_t sum = 0;
uint32_t iph_len = iph->ihl*4;
-@@ -46,13 +52,13 @@ uint16_t nfq_checksum_tcpudp_ipv4(struct iphdr *iph)
+@@ -46,13 +52,13 @@ uint16_t nfq_checksum_tcpudp_ipv4(struct
sum += (iph->saddr) & 0xFFFF;
sum += (iph->daddr >> 16) & 0xFFFF;
sum += (iph->daddr) & 0xFFFF;
@@ -49,7 +49,7 @@
{
uint32_t sum = 0;
uint32_t hdr_len = (uint32_t *)transport_hdr - (uint32_t *)ip6h;
-@@ -68,7 +74,7 @@ uint16_t nfq_checksum_tcpudp_ipv6(struct ip6_hdr *ip6h, void *transport_hdr)
+@@ -68,7 +74,7 @@ uint16_t nfq_checksum_tcpudp_ipv6(struct
sum += (ip6h->ip6_dst.s6_addr16[i] >> 16) & 0xFFFF;
sum += (ip6h->ip6_dst.s6_addr16[i]) & 0xFFFF;
}
@@ -58,11 +58,9 @@
sum += htons(ip6h->ip6_plen);
return nfq_checksum(sum, (uint16_t *)payload, len);
-diff --git a/src/extra/tcp.c b/src/extra/tcp.c
-index d1cd79d..a66f392 100644
--- a/src/extra/tcp.c
+++ b/src/extra/tcp.c
-@@ -96,7 +96,7 @@ nfq_tcp_compute_checksum_ipv4(struct tcphdr *tcph, struct iphdr *iph)
+@@ -96,7 +96,7 @@ nfq_tcp_compute_checksum_ipv4(struct tcp
{
/* checksum field in header needs to be zero for calculation. */
tcph->check = 0;
@@ -71,7 +69,7 @@ index d1cd79d..a66f392 100644
}
EXPORT_SYMBOL(nfq_tcp_compute_checksum_ipv4);
-@@ -110,7 +110,7 @@ nfq_tcp_compute_checksum_ipv6(struct tcphdr *tcph, struct ip6_hdr *ip6h)
+@@ -110,7 +110,7 @@ nfq_tcp_compute_checksum_ipv6(struct tcp
{
/* checksum field in header needs to be zero for calculation. */
tcph->check = 0;
@@ -82,7 +80,7 @@ index d1cd79d..a66f392 100644
--- a/src/extra/udp.c
+++ b/src/extra/udp.c
-@@ -96,7 +96,7 @@ nfq_udp_compute_checksum_ipv4(struct udphdr *udph, struct iphdr *iph)
+@@ -96,7 +96,7 @@ nfq_udp_compute_checksum_ipv4(struct udp
{
/* checksum field in header needs to be zero for calculation. */
udph->check = 0;
@@ -91,7 +89,7 @@ index d1cd79d..a66f392 100644
}
EXPORT_SYMBOL(nfq_udp_compute_checksum_ipv4);
-@@ -115,7 +115,7 @@ nfq_udp_compute_checksum_ipv6(struct udphdr *udph, struct ip6_hdr *ip6h)
+@@ -115,7 +115,7 @@ nfq_udp_compute_checksum_ipv6(struct udp
{
/* checksum field in header needs to be zero for calculation. */
udph->check = 0;