aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libjson-c/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-07-04 00:56:19 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2022-07-04 20:37:41 +0200
commit341121edd49428acb992ce34b27e51454ca904cf (patch)
tree05bbe22e041542becf399b103ff3b45dca3a808a /package/libs/libjson-c/Makefile
parenta0c5b03e02528b938f1c6d411a582b67b7e9fe7b (diff)
downloadupstream-341121edd49428acb992ce34b27e51454ca904cf.tar.gz
upstream-341121edd49428acb992ce34b27e51454ca904cf.tar.bz2
upstream-341121edd49428acb992ce34b27e51454ca904cf.zip
libjson-c: disable libbsd
libjson-c is happy to pick up libbsd both on the host and target. Reproducible with make package/libbsd/compile;make package/libjson-c/compile Also fixes host compilation on Arch Linux for a similar reason. Undefined reference to arc4random. Fixes: f3a198697f60 ("libjson-c: update to 0.16") Acked-by: Thomas Huehn thomas.huehn@hs-nordhausen.de Acked-by: Nick Hainke vincent@systemli.org Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs/libjson-c/Makefile')
-rw-r--r--package/libs/libjson-c/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/libs/libjson-c/Makefile b/package/libs/libjson-c/Makefile
index 2b90c27a4a..2c312f200e 100644
--- a/package/libs/libjson-c/Makefile
+++ b/package/libs/libjson-c/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=json-c
PKG_VERSION:=0.16
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nodoc.tar.gz
PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
@@ -27,8 +27,12 @@ include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
CMAKE_HOST_OPTIONS += \
+ -DDISABLE_EXTRA_LIBS=TRUE \
-DBUILD_SHARED_LIBS=FALSE
+CMAKE_OPTIONS += \
+ -DDISABLE_EXTRA_LIBS=TRUE
+
define Package/libjson-c
SECTION:=libs
CATEGORY:=Libraries