aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libiconv
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-01-10 18:43:57 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-01-10 22:15:37 +0100
commit77beaf2ec91bba0a0202ea63877ed3b399effabf (patch)
treecf7f16585546f96a575a1e4630ddd963dcc1f623 /package/libs/libiconv
parent7480d3309cbe40378da48c3b6decc4ba2b1fc3d5 (diff)
downloadupstream-77beaf2ec91bba0a0202ea63877ed3b399effabf.tar.gz
upstream-77beaf2ec91bba0a0202ea63877ed3b399effabf.tar.bz2
upstream-77beaf2ec91bba0a0202ea63877ed3b399effabf.zip
package: replace $(STAGING_DIR)/host with $(STAGING_DIR_HOSTPKG)
Cleanup to prepare for changing STAGING_DIR_HOSTPKG. The actual change of STAGING_DIR_HOSTPKG (i.e., moving the host packages back into a common, not target-specific directory) will be done after the first LEDE release, but the cleanup will also be useful for projects like Gluon. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'package/libs/libiconv')
-rw-r--r--package/libs/libiconv/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/libs/libiconv/Makefile b/package/libs/libiconv/Makefile
index 0cb7cc7254..4d7dcd3498 100644
--- a/package/libs/libiconv/Makefile
+++ b/package/libs/libiconv/Makefile
@@ -65,14 +65,14 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR)/host/lib
- $(INSTALL_DATA) $(HOST_BUILD_DIR)/libiconv.a $(STAGING_DIR)/host/lib/
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/lib
+ $(INSTALL_DATA) $(HOST_BUILD_DIR)/libiconv.a $(STAGING_DIR_HOSTPKG)/lib/
- $(INSTALL_DIR) $(STAGING_DIR)/host/include
- $(INSTALL_DATA) ./src/include/iconv.h $(STAGING_DIR)/host/include/
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/include
+ $(INSTALL_DATA) ./src/include/iconv.h $(STAGING_DIR_HOSTPKG)/include/
- $(INSTALL_DIR) $(STAGING_DIR)/host/share/aclocal
- $(INSTALL_DATA) ./src/m4/* $(STAGING_DIR)/host/share/aclocal/
+ $(INSTALL_DIR) $(STAGING_DIR_HOSTPKG)/share/aclocal
+ $(INSTALL_DATA) ./src/m4/* $(STAGING_DIR_HOSTPKG)/share/aclocal/
endef
$(eval $(call HostBuild))