aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libcxx/patches/010-ssp.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-05 01:21:05 -0800
committerPaul Spooren <mail@aparcar.org>2020-12-07 10:46:43 -1000
commitf7d7a3a18b1f1d1fdcf5b05f4ab1af6b8fc2ce1e (patch)
tree06bcfcd5c08d28b5c5e96800e782662fbafd61d1 /package/libs/libcxx/patches/010-ssp.patch
parent0ba83a757728185eabd965e07331508923cca825 (diff)
downloadupstream-f7d7a3a18b1f1d1fdcf5b05f4ab1af6b8fc2ce1e.tar.gz
upstream-f7d7a3a18b1f1d1fdcf5b05f4ab1af6b8fc2ce1e.tar.bz2
upstream-f7d7a3a18b1f1d1fdcf5b05f4ab1af6b8fc2ce1e.zip
libcxx[abi]: remove
This is a neat project, but offers no benefit to OpenWrt. The initial reason for it was to be a replacement for libstdcpp as it is smaller and lacks compatibility for C++98. Unfortunately, compiling several packages with it results in larger ipk sizes. While not a member of the packages feed, this will be moved to packages-abandoned to keep it somewhere. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs/libcxx/patches/010-ssp.patch')
-rw-r--r--package/libs/libcxx/patches/010-ssp.patch13
1 files changed, 0 insertions, 13 deletions
diff --git a/package/libs/libcxx/patches/010-ssp.patch b/package/libs/libcxx/patches/010-ssp.patch
deleted file mode 100644
index f83c7b9b56..0000000000
--- a/package/libs/libcxx/patches/010-ssp.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -760,6 +760,10 @@ function(cxx_link_system_libraries targe
- target_link_libraries(${target} PRIVATE atomic)
- endif()
-
-+ if (LIBCXX_HAS_MUSL_LIBC)
-+ target_link_libraries(${target} PRIVATE ssp_nonshared)
-+ endif()
-+
- if (MINGW)
- target_link_libraries(${target} PRIVATE "${MINGW_LIBRARIES}")
- endif()