aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/jansson
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-03-28 11:27:27 +0000
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-03-29 17:27:54 +0100
commit9e835377ada3f8a44a95e822e0f81f71b466f1c9 (patch)
tree4850c61d8f121a4aa70d633a72722a532cc565fa /package/libs/jansson
parent3a761c90afc0af1a17a03241534508b52a235410 (diff)
downloadupstream-9e835377ada3f8a44a95e822e0f81f71b466f1c9.tar.gz
upstream-9e835377ada3f8a44a95e822e0f81f71b466f1c9.tar.bz2
upstream-9e835377ada3f8a44a95e822e0f81f71b466f1c9.zip
jansson: import jansson from packages
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'package/libs/jansson')
-rw-r--r--package/libs/jansson/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/package/libs/jansson/Makefile b/package/libs/jansson/Makefile
new file mode 100644
index 0000000000..880d372116
--- /dev/null
+++ b/package/libs/jansson/Makefile
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2011-2017 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=jansson
+PKG_VERSION:=2.12
+PKG_RELEASE:=1
+PKG_LICENSE:=MIT
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.digip.org/jansson/releases/
+PKG_HASH:=645d72cc5dbebd4df608d33988e55aa42a7661039e19a379fcbe5c79d1aee1d2
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/jansson
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Jansson library
+ URL:=http://www.digip.org/jansson/
+ MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
+endef
+
+define Package/jansson/description
+ Jansson is a C library for encoding, decoding and manipulating JSON data
+endef
+
+TARGET_CFLAGS += $(FPIC)
+TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib -lm
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/{lib,include}
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjansson* $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+endef
+
+define Package/jansson/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjansson*so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,jansson))