aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/gettext-full
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2016-12-12 14:20:58 +0200
committerFelix Fietkau <nbd@nbd.name>2016-12-22 16:42:20 +0100
commitacfb06783500a6364b3e473b6c02d06156829f70 (patch)
tree7e8b82bf810d6033ddfdf4abe5ca97f556363599 /package/libs/gettext-full
parent1831e616999cc081c83219fc504f4e73eb098612 (diff)
downloadupstream-acfb06783500a6364b3e473b6c02d06156829f70.tar.gz
upstream-acfb06783500a6364b3e473b6c02d06156829f70.tar.bz2
upstream-acfb06783500a6364b3e473b6c02d06156829f70.zip
gettext-full: enforce only static lib on the host build
Sometimes I'm getting error on the host-side build: ``` /usr/lib64/gcc/x86_64-suse-linux/4.8/../../../../x86_64-suse-linux/bin/ld: /home/sandu/work/lede/staging_dir/host/lib/liblzma.a(liblzma_la-common.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC /home/sandu/work/lede/staging_dir/host/lib/liblzma.a: error adding symbols: Bad value collect2: error: ld returned 1 exit status Makefile:2847: recipe for target 'libgettextlib.la' failed make[9]: *** [libgettextlib.la] Error 1 make[9]: Leaving directory '/home/sandu/work/lede/build_dir/target-x86_64_musl-1.1.15/host/gettext-0.19.8.1/gettext-tools/gnulib-lib' Makefile:2597: recipe for target 'all' failed ``` Disabling the shared-lib build, seems to fix this. This is when building glib2 on the host-side. glib2 is required by newer QEMU package [which is in the feeds]. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'package/libs/gettext-full')
-rw-r--r--package/libs/gettext-full/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libs/gettext-full/Makefile b/package/libs/gettext-full/Makefile
index fc2deaf31d..64d27609c3 100644
--- a/package/libs/gettext-full/Makefile
+++ b/package/libs/gettext-full/Makefile
@@ -59,6 +59,8 @@ CONFIGURE_ARGS += \
--without-emacs
HOST_CONFIGURE_ARGS += \
+ --disable-shared \
+ --enable-static \
--disable-libasprintf \
--disable-rpath \
--disable-java \