aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/gettext-full/Makefile
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-04-16 18:32:14 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-04 06:07:31 +0200
commitd167adbc4418b664dd825b8b4e7085c2c7322271 (patch)
treed82791e38c1a3b58227c2832252042d0e9f7fc7e /package/libs/gettext-full/Makefile
parent09f8f21ae33402201c14a125a37b64746415642d (diff)
downloadupstream-d167adbc4418b664dd825b8b4e7085c2c7322271.tar.gz
upstream-d167adbc4418b664dd825b8b4e7085c2c7322271.tar.bz2
upstream-d167adbc4418b664dd825b8b4e7085c2c7322271.zip
gettext-full: bootstrap to local gnulib source
Using the local gnulib source during autogen.sh allows for fine-grained control over the macros and source files for use with gettext but part of gnulib instead of gettext, without having to wait for a release or deal with gnulib as a git submodule. This is an alternative to running autoreconf. It also removes the need to patch macros in the case where there is a conflict between the source and our aclocal directory. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'package/libs/gettext-full/Makefile')
-rw-r--r--package/libs/gettext-full/Makefile41
1 files changed, 39 insertions, 2 deletions
diff --git a/package/libs/gettext-full/Makefile b/package/libs/gettext-full/Makefile
index a92932f375..c8700de550 100644
--- a/package/libs/gettext-full/Makefile
+++ b/package/libs/gettext-full/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gettext-full
PKG_VERSION:=0.21.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=gettext-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gettext
@@ -21,7 +21,6 @@ PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=GPL-3.0-or-later
PKG_CPE_ID:=cpe:/a:gnu:gettext
-PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_DEPENDS:=gettext-full/host libxml2
PKG_BUILD_PARALLEL:=0
@@ -69,6 +68,8 @@ define Package/libintl-full
ABI_VERSION:=8
endef
+export GNULIB_SRCDIR:=$(HOST_GNULIB_SRCDIR)
+
TARGET_CFLAGS += $(FPIC)
ifneq ($(HOST_OS),Linux)
TARGET_CFLAGS += -I$(STAGING_DIR_HOSTPKG)/include
@@ -107,11 +108,47 @@ HOST_CONFIGURE_VARS += \
HOST_CFLAGS += $(HOST_FPIC)
+define Host/Bootstrap
+ ( \
+ cd $(HOST_BUILD_DIR); \
+ $(AM_TOOL_PATHS) \
+ ./autogen.sh \
+ )
+endef
+
+define Host/Prepare
+ $(call Host/Prepare/Default)
+ $(if $(QUILT),,$(call Host/Bootstrap))
+endef
+
+define Host/Configure
+ $(if $(QUILT),$(call Host/Bootstrap))
+ $(call Host/Configure/Default)
+endef
+
define Host/Compile
$(foreach makefile,$(PKG_MAKEFILES_FAKE),printf '%s\n%s\n' 'all:' 'install:' > $(HOST_BUILD_DIR)/$(makefile); )
$(call Host/Compile/Default,SUBDIRS='$(PKG_SUBDIRS)')
endef
+define Build/Bootstrap
+ ( \
+ cd $(PKG_BUILD_DIR); \
+ $(AM_TOOL_PATHS) \
+ ./autogen.sh \
+ )
+endef
+
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ $(if $(QUILT),,$(call Build/Bootstrap))
+endef
+
+define Build/Configure
+ $(if $(QUILT),$(call Build/Bootstrap))
+ $(call Build/Configure/Default)
+endef
+
define Build/Compile
$(foreach makefile,$(PKG_MAKEFILES_FAKE),printf '%s\n%s\n' 'all:' 'install:' > $(PKG_BUILD_DIR)/$(makefile); )
$(call Build/Compile/Default,SUBDIRS='$(PKG_SUBDIRS)')