aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-25 18:57:08 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-25 18:59:46 +0100
commitf4d6e8f98f18dbd179b1396ac14788ee7d1c137e (patch)
treeb0f781c2185d6159bd709025714897ecf1e4c7a6 /package/libs/elfutils
parenteaaee181d194f8908a70833b3298392622bc5c86 (diff)
downloadupstream-f4d6e8f98f18dbd179b1396ac14788ee7d1c137e.tar.gz
upstream-f4d6e8f98f18dbd179b1396ac14788ee7d1c137e.tar.bz2
upstream-f4d6e8f98f18dbd179b1396ac14788ee7d1c137e.zip
libelf: fix library packaging
The library has an usual shared object file name, which caused the install glob pattern to miss the actual so. Fixes: #2082 Fixes; 0e70f69a35 ("treewide: revise library packaging") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index a980d35ea8..a67b49ce07 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
PKG_VERSION:=0.175
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
@@ -91,7 +91,7 @@ endef
define Package/libelf/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf*.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf{-*.so,*.so.*} $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libasm))