aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-12-20 08:04:46 +0100
committerJo-Philipp Wich <jo@mein.io>2018-12-20 08:13:24 +0100
commitf2c6e2c3850e016dcae7afa48086b8feabd0af12 (patch)
tree35db3692129de05a839bda8ec8b613eb35c39e52 /package/libs/elfutils
parent99ddff0c7f836e05156a0a084b2895ef2607811d (diff)
downloadupstream-f2c6e2c3850e016dcae7afa48086b8feabd0af12.tar.gz
upstream-f2c6e2c3850e016dcae7afa48086b8feabd0af12.tar.bz2
upstream-f2c6e2c3850e016dcae7afa48086b8feabd0af12.zip
elfutils: produce correct libelf.pc file when building with full nls
When building with full lagnuage support, libelf.so will depend on and link with libintl.so so we need to change the pkg-config template to reflect this library dependency. Also change the Makefile to only pass --disable-nls to configure when the full nls support is actually disabled in the buildroot config. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile7
-rw-r--r--package/libs/elfutils/patches/003-libintl-compatibility.patch (renamed from package/libs/elfutils/patches/003-libint-stub.patch)23
2 files changed, 27 insertions, 3 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 9fff14d283..8ac3a01176 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
PKG_VERSION:=0.174
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
@@ -54,12 +54,13 @@ define Package/libelf1
endef
ifeq ($(CONFIG_BUILD_NLS),y)
-TARGET_LDFLAGS += "-lintl"
+TARGET_LDFLAGS += -lintl
+else
+CONFIGURE_ARGS += --disable-nls
endif
CONFIGURE_ARGS += \
--program-prefix=eu- \
- --disable-nls \
--without-lzma
TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result -Wno-format-nonliteral
diff --git a/package/libs/elfutils/patches/003-libint-stub.patch b/package/libs/elfutils/patches/003-libintl-compatibility.patch
index 24cad74328..35a27113eb 100644
--- a/package/libs/elfutils/patches/003-libint-stub.patch
+++ b/package/libs/elfutils/patches/003-libintl-compatibility.patch
@@ -47,3 +47,26 @@
/* gettext helper macros. */
#define _(Str) dgettext ("elfutils", Str)
+--- a/config/libelf.pc.in
++++ b/config/libelf.pc.in
+@@ -8,7 +8,7 @@ Description: elfutils libelf library to
+ Version: @VERSION@
+ URL: http://elfutils.org/
+
+-Libs: -L${libdir} -lelf
++Libs: -L${libdir} -lelf @intl_LDFLAGS@
+ Cflags: -I${includedir}
+
+ Requires.private: zlib
+--- a/configure.ac
++++ b/configure.ac
+@@ -538,6 +538,9 @@ AC_CONFIG_FILES([config/libelf.pc config
+ AC_SUBST(USE_NLS, yes)
+ AM_PO_SUBDIRS
+
++case "$USE_NLS" in yes) intl_LDFLAGS="-lintl" ;; esac
++AC_SUBST([intl_LDFLAGS])
++
+ dnl Appended to the config.h file.
+ dnl We hide all kinds of configuration magic in lib/eu-config.h.
+ AH_BOTTOM([#include <eu-config.h>])