aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2016-10-13 21:02:47 -0300
committerFelix Fietkau <nbd@nbd.name>2016-11-03 11:08:02 +0100
commite2fd98793e60306a06427a9374e893d380373ef1 (patch)
tree28ede4cc131fea7c058aad19e4ee7d3e1c7a22cb /package/libs/elfutils
parentcb037d1842d93b37457c896a8949e135ed6e0065 (diff)
downloadupstream-e2fd98793e60306a06427a9374e893d380373ef1.tar.gz
upstream-e2fd98793e60306a06427a9374e893d380373ef1.tar.bz2
upstream-e2fd98793e60306a06427a9374e893d380373ef1.zip
elfutils: bump to 0.167
Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile7
-rw-r--r--package/libs/elfutils/patches/003-libint-stub.patch4
-rw-r--r--package/libs/elfutils/patches/004-memcpy_def.patch8
-rw-r--r--package/libs/elfutils/patches/005-build_only_libs.patch2
-rw-r--r--package/libs/elfutils/patches/006-libdw_LIBS.patch2
-rw-r--r--package/libs/elfutils/patches/100-musl-compat.patch90
-rw-r--r--package/libs/elfutils/patches/101-no-fts.patch4
-rw-r--r--package/libs/elfutils/patches/110-elf_compressed_header_support.patch33
8 files changed, 16 insertions, 134 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 5292eba264..46ad1b3d91 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -1,5 +1,6 @@
#
# Copyright (C) 2010-2014 OpenWrt.org
+# Copyright (C) 2016 Luiz Angelo Daros de Luca <luizluca@gmail.com>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
-PKG_VERSION:=0.165
+PKG_VERSION:=0.167
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/$(PKG_NAME)/$(PKG_VERSION)
-PKG_MD5SUM:=c37fdbe18e848002b451562cba964679
+PKG_MD5SUM:=efc6c2067dfad5646777e93e85222e8f
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=GPL-3.0+
PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
@@ -35,7 +36,7 @@ endef
define Package/libasm
$(call Package/elfutils/Default)
TITLE+= (libasm)
- DEPENDS:=libelf1
+ DEPENDS:=libelf1 +libdw
endef
define Package/libdw
diff --git a/package/libs/elfutils/patches/003-libint-stub.patch b/package/libs/elfutils/patches/003-libint-stub.patch
index d6cc7070e6..0aa31a86cb 100644
--- a/package/libs/elfutils/patches/003-libint-stub.patch
+++ b/package/libs/elfutils/patches/003-libint-stub.patch
@@ -37,9 +37,9 @@
--- a/libasm/libasmP.h
+++ b/libasm/libasmP.h
-@@ -33,6 +33,9 @@
+@@ -35,6 +35,9 @@
- #include <libasm.h>
+ #include "libdwelf.h"
+#ifdef _ /* fix libintl-stub */
+#undef _
diff --git a/package/libs/elfutils/patches/004-memcpy_def.patch b/package/libs/elfutils/patches/004-memcpy_def.patch
index 0b030bed5d..3731592b14 100644
--- a/package/libs/elfutils/patches/004-memcpy_def.patch
+++ b/package/libs/elfutils/patches/004-memcpy_def.patch
@@ -1,8 +1,8 @@
--- a/libelf/libelf.h
+++ b/libelf/libelf.h
-@@ -35,6 +35,11 @@
- /* Get the ELF types. */
- #include <elf.h>
+@@ -108,6 +108,11 @@ typedef struct
+ size_t d_align; /* Alignment in section. */
+ } Elf_Data;
+#ifndef _LIBC
+#ifndef __mempcpy
@@ -10,5 +10,5 @@
+#endif
+#endif
- /* Known translation types. */
+ /* Commands for `...'. */
typedef enum
diff --git a/package/libs/elfutils/patches/005-build_only_libs.patch b/package/libs/elfutils/patches/005-build_only_libs.patch
index e39b395687..7c30efc9fd 100644
--- a/package/libs/elfutils/patches/005-build_only_libs.patch
+++ b/package/libs/elfutils/patches/005-build_only_libs.patch
@@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -378,8 +378,7 @@ AM_MAKEFLAGS = --no-print-directory
+@@ -377,8 +377,7 @@ AM_MAKEFLAGS = --no-print-directory
pkginclude_HEADERS = version.h
# Add doc back when we have some real content.
diff --git a/package/libs/elfutils/patches/006-libdw_LIBS.patch b/package/libs/elfutils/patches/006-libdw_LIBS.patch
index 34c4447708..80c20ad5f0 100644
--- a/package/libs/elfutils/patches/006-libdw_LIBS.patch
+++ b/package/libs/elfutils/patches/006-libdw_LIBS.patch
@@ -1,6 +1,6 @@
--- a/libdw/Makefile.in
+++ b/libdw/Makefile.in
-@@ -996,7 +996,7 @@ libdw.so$(EXEEXT): $(srcdir)/libdw.map l
+@@ -1002,7 +1002,7 @@ libdw.so$(EXEEXT): $(srcdir)/libdw.map l
-Wl,--enable-new-dtags,-rpath,$(pkglibdir) \
-Wl,--version-script,$<,--no-undefined \
-Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
diff --git a/package/libs/elfutils/patches/100-musl-compat.patch b/package/libs/elfutils/patches/100-musl-compat.patch
index 25e15047a5..f345c3a9a6 100644
--- a/package/libs/elfutils/patches/100-musl-compat.patch
+++ b/package/libs/elfutils/patches/100-musl-compat.patch
@@ -116,70 +116,6 @@
#include <fcntl.h>
#include <gelf.h>
#include <libdw.h>
---- a/src/i386_ld.c
-+++ b/src/i386_ld.c
-@@ -20,7 +20,7 @@
- #endif
-
- #include <assert.h>
--#include <error.h>
-+#include <err.h>
- #include <libintl.h>
- #include <stdlib.h>
- #include <string.h>
---- a/src/ld.c
-+++ b/src/ld.c
-@@ -21,7 +21,7 @@
-
- #include <argp.h>
- #include <assert.h>
--#include <error.h>
-+#include <err.h>
- #include <fcntl.h>
- #include <libelf.h>
- #include <libintl.h>
---- a/src/ldgeneric.c
-+++ b/src/ldgeneric.c
-@@ -23,7 +23,7 @@
- #include <ctype.h>
- #include <dlfcn.h>
- #include <errno.h>
--#include <error.h>
-+#include <err.h>
- #include <fcntl.h>
- #include <fnmatch.h>
- #include <gelf.h>
---- a/src/ldlex.c
-+++ b/src/ldlex.c
-@@ -1106,7 +1106,7 @@ char *ldtext;
- #include <assert.h>
- #include <ctype.h>
- #include <elf.h>
--#include <error.h>
-+#include <err.h>
- #include <inttypes.h>
- #include <libintl.h>
- #include <stdbool.h>
---- a/src/ldscript.c
-+++ b/src/ldscript.c
-@@ -95,7 +95,7 @@
- #endif
-
- #include <assert.h>
--#include <error.h>
-+#include <err.h>
- #include <libintl.h>
- #include <stdbool.h>
- #include <stdint.h>
-@@ -106,7 +106,7 @@
- #include <system.h>
- #include <ld.h>
-
--/* The error handler. */
-+/* The err.handler. */
- static void yyerror (const char *s);
-
- /* Some helper functions we need to construct the data structures
--- a/src/nm.c
+++ b/src/nm.c
@@ -26,7 +26,7 @@
@@ -388,7 +324,7 @@
+#include <err.h>
#include <unistd.h>
#include <dwarf.h>
- #include <sys/resource.h>
+
--- a/tests/dwfl-bug-getmodules.c
+++ b/tests/dwfl-bug-getmodules.c
@@ -18,7 +18,7 @@
@@ -681,28 +617,6 @@
#include <libelfP.h>
#include <dwarf.h>
#include <stdlib.h>
---- a/src/ldlex.l
-+++ b/src/ldlex.l
-@@ -23,7 +23,7 @@
- #include <assert.h>
- #include <ctype.h>
- #include <elf.h>
--#include <error.h>
-+#include <err.h>
- #include <inttypes.h>
- #include <libintl.h>
- #include <stdbool.h>
---- a/libebl/eblwstrtab.c
-+++ b/libebl/eblwstrtab.c
-@@ -305,7 +305,7 @@ copystrings (struct Ebl_WStrent *nodep,
-
- /* Process the current node. */
- nodep->offset = *offsetp;
-- *freep = wmempcpy (*freep, nodep->string, nodep->len);
-+ *freep = wmemcpy (*freep, nodep->string, nodep->len) + nodep->len;
- *offsetp += nodep->len * sizeof (wchar_t);
-
- for (subs = nodep->next; subs != NULL; subs = subs->next)
--- a/libdwfl/dwfl_error.c
+++ b/libdwfl/dwfl_error.c
@@ -140,6 +140,7 @@ __libdwfl_seterrno (Dwfl_Error error)
@@ -755,7 +669,7 @@
typedef struct Dwfl Dwfl;
--- a/libdwfl/find-debuginfo.c
+++ b/libdwfl/find-debuginfo.c
-@@ -372,7 +372,7 @@ dwfl_standard_find_debuginfo (Dwfl_Modul
+@@ -385,7 +385,7 @@ dwfl_standard_find_debuginfo (Dwfl_Modul
/* If FILE_NAME is a symlink, the debug file might be associated
with the symlink target name instead. */
diff --git a/package/libs/elfutils/patches/101-no-fts.patch b/package/libs/elfutils/patches/101-no-fts.patch
index 6a3e9408d6..124563c787 100644
--- a/package/libs/elfutils/patches/101-no-fts.patch
+++ b/package/libs/elfutils/patches/101-no-fts.patch
@@ -90,7 +90,7 @@
dwfl_addrmodule.$(OBJEXT) dwfl_addrdwarf.$(OBJEXT) \
cu.$(OBJEXT) dwfl_module_nextcu.$(OBJEXT) \
dwfl_nextcu.$(OBJEXT) dwfl_cumodule.$(OBJEXT) \
-@@ -425,7 +425,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
+@@ -432,7 +432,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
find-debuginfo.c dwfl_build_id_find_elf.c \
@@ -99,7 +99,7 @@
linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
-@@ -562,7 +562,6 @@ distclean-compile:
+@@ -569,7 +569,6 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lines.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/link_map.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-core-attach.Po@am__quote@
diff --git a/package/libs/elfutils/patches/110-elf_compressed_header_support.patch b/package/libs/elfutils/patches/110-elf_compressed_header_support.patch
deleted file mode 100644
index 419e694646..0000000000
--- a/package/libs/elfutils/patches/110-elf_compressed_header_support.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/libelf/libelf.h
-+++ b/libelf/libelf.h
-@@ -36,6 +36,30 @@
- /* Get the ELF types. */
- #include <elf.h>
-
-+#ifndef ELFCOMPRESS_ZLIB
-+typedef struct
-+{
-+ Elf32_Word ch_type; /* Compression format. */
-+ Elf32_Word ch_size; /* Uncompressed data size. */
-+ Elf32_Word ch_addralign; /* Uncompressed data alignment. */
-+} Elf32_Chdr;
-+
-+typedef struct
-+{
-+ Elf64_Word ch_type; /* Compression format. */
-+ Elf64_Word ch_reserved;
-+ Elf64_Xword ch_size; /* Uncompressed data size. */
-+ Elf64_Xword ch_addralign; /* Uncompressed data alignment. */
-+} Elf64_Chdr;
-+
-+/* Legal values for ch_type (compression algorithm). */
-+#define ELFCOMPRESS_ZLIB 1 /* ZLIB/DEFLATE algorithm. */
-+#define ELFCOMPRESS_LOOS 0x60000000 /* Start of OS-specific. */
-+#define ELFCOMPRESS_HIOS 0x6fffffff /* End of OS-specific. */
-+#define ELFCOMPRESS_LOPROC 0x70000000 /* Start of processor-specific. */
-+#define ELFCOMPRESS_HIPROC 0x7fffffff /* End of processor-specific. */
-+#endif
-+
- #ifndef _LIBC
- #ifndef __mempcpy
- #define __mempcpy mempcpy