aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-24 12:52:23 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-24 12:52:23 +0100
commitd7bf0898a8b411bc40ab05dfaf80897a2fffd69e (patch)
tree5777cbad83ee3e755a0c3edfc35097f6b956e85b /package/libs/elfutils
parent790bce92adce6fc52a5fe68ac05b1018e171af28 (diff)
downloadupstream-d7bf0898a8b411bc40ab05dfaf80897a2fffd69e.tar.gz
upstream-d7bf0898a8b411bc40ab05dfaf80897a2fffd69e.tar.bz2
upstream-d7bf0898a8b411bc40ab05dfaf80897a2fffd69e.zip
elfutils: rename libelf1 to libelf
The ABI_VERSION:=1 tag will take care of transforming the binary library package basename. Add a virtual PROVIDES:=libelf1 for packages still having libelf1 in their DEPENDS:=... lists. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 3ee1c472a1..a980d35ea8 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -39,19 +39,20 @@ endef
define Package/libasm
$(call Package/elfutils/Default)
TITLE+= (libasm)
- DEPENDS:=libelf1 +libdw
+ DEPENDS:=libelf +libdw
endef
define Package/libdw
$(call Package/elfutils/Default)
- DEPENDS:=libelf1 +libbz2
+ DEPENDS:=libelf +libbz2
TITLE+= (libdw)
endef
-define Package/libelf1
+define Package/libelf
$(call Package/elfutils/Default)
DEPENDS:=$(INTL_DEPENDS) +zlib
TITLE+= (libelf)
+ PROVIDES:=libelf1
endef
ifeq ($(CONFIG_BUILD_NLS),y)
@@ -88,11 +89,11 @@ define Package/libdw/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdw*.so.* $(1)/usr/lib/
endef
-define Package/libelf1/install
+define Package/libelf/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf*.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libasm))
$(eval $(call BuildPackage,libdw))
-$(eval $(call BuildPackage,libelf1))
+$(eval $(call BuildPackage,libelf))