aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 13:54:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 13:54:13 +0000
commit99fb7d9a4e88875c28c2b76a4acdd42c5c9fe160 (patch)
tree102b5a042ceb02a1bb0aaa1ee1a95813bd859e1f /package/libs/elfutils
parent99856ebf5cbdd520cf58cef9cf2323a4a6168ebc (diff)
downloadupstream-99fb7d9a4e88875c28c2b76a4acdd42c5c9fe160.tar.gz
upstream-99fb7d9a4e88875c28c2b76a4acdd42c5c9fe160.tar.bz2
upstream-99fb7d9a4e88875c28c2b76a4acdd42c5c9fe160.zip
elfutils: bump to 0.165
Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com> SVN-Revision: 48393
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile8
-rw-r--r--package/libs/elfutils/patches/003-libint-stub.patch2
-rw-r--r--package/libs/elfutils/patches/005-build_only_libs.patch4
-rw-r--r--package/libs/elfutils/patches/006-libdw_LIBS.patch6
-rw-r--r--package/libs/elfutils/patches/100-musl-compat.patch4
-rw-r--r--package/libs/elfutils/patches/101-no-fts.patch4
6 files changed, 14 insertions, 14 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index b1e52ba5cf..fa7bc5542e 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
-PKG_VERSION:=0.164
+PKG_VERSION:=0.165
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/$(PKG_NAME)/$(PKG_VERSION)
-PKG_MD5SUM:=2e4536c1c48034f188a80789a59114d8
+PKG_MD5SUM:=c37fdbe18e848002b451562cba964679
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=GPL-3.0+
PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
@@ -28,7 +28,6 @@ include $(INCLUDE_DIR)/nls.mk
define Package/elfutils/Default
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=$(INTL_DEPENDS)
TITLE:=ELF manipulation libraries
URL:=https://fedorahosted.org/elfutils/
endef
@@ -41,12 +40,13 @@ endef
define Package/libdw
$(call Package/elfutils/Default)
- DEPENDS:=libelf1 +zlib +libbz2
+ DEPENDS:=libelf1 +libbz2
TITLE+= (libdw)
endef
define Package/libelf1
$(call Package/elfutils/Default)
+ DEPENDS:=$(INTL_DEPENDS) +zlib
TITLE+= (libelf)
endef
diff --git a/package/libs/elfutils/patches/003-libint-stub.patch b/package/libs/elfutils/patches/003-libint-stub.patch
index cf6539f0ec..d6cc7070e6 100644
--- a/package/libs/elfutils/patches/003-libint-stub.patch
+++ b/package/libs/elfutils/patches/003-libint-stub.patch
@@ -1,6 +1,6 @@
--- a/libelf/libelfP.h
+++ b/libelf/libelfP.h
-@@ -42,6 +42,9 @@
+@@ -43,6 +43,9 @@
#include <stdio.h>
#include <string.h>
diff --git a/package/libs/elfutils/patches/005-build_only_libs.patch b/package/libs/elfutils/patches/005-build_only_libs.patch
index 0077369844..e39b395687 100644
--- a/package/libs/elfutils/patches/005-build_only_libs.patch
+++ b/package/libs/elfutils/patches/005-build_only_libs.patch
@@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -372,8 +372,7 @@ ACLOCAL_AMFLAGS = -I m4
+@@ -378,8 +378,7 @@ AM_MAKEFLAGS = --no-print-directory
pkginclude_HEADERS = version.h
# Add doc back when we have some real content.
@@ -12,7 +12,7 @@
COPYING COPYING-GPLV2 COPYING-LGPLV3
--- a/Makefile.am
+++ b/Makefile.am
-@@ -23,8 +23,7 @@ ACLOCAL_AMFLAGS = -I m4
+@@ -27,8 +27,7 @@ AM_MAKEFLAGS = --no-print-directory
pkginclude_HEADERS = version.h
# Add doc back when we have some real content.
diff --git a/package/libs/elfutils/patches/006-libdw_LIBS.patch b/package/libs/elfutils/patches/006-libdw_LIBS.patch
index bcea1005c5..34c4447708 100644
--- a/package/libs/elfutils/patches/006-libdw_LIBS.patch
+++ b/package/libs/elfutils/patches/006-libdw_LIBS.patch
@@ -1,11 +1,11 @@
--- a/libdw/Makefile.in
+++ b/libdw/Makefile.in
-@@ -994,7 +994,7 @@ libdw.so$(EXEEXT): $(srcdir)/libdw.map l
+@@ -996,7 +996,7 @@ libdw.so$(EXEEXT): $(srcdir)/libdw.map l
-Wl,--enable-new-dtags,-rpath,$(pkglibdir) \
-Wl,--version-script,$<,--no-undefined \
-Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
-- -ldl $(argp_LDADD) $(zip_LIBS)
-+ -ldl $(argp_LDADD) $(zip_LIBS) $(LIBS)
+- -ldl -lz $(argp_LDADD) $(zip_LIBS)
++ -ldl -lz $(argp_LDADD) $(zip_LIBS) $(LIBS)
@$(textrel_check)
$(AM_V_at)ln -fs $@ $@.$(VERSION)
diff --git a/package/libs/elfutils/patches/100-musl-compat.patch b/package/libs/elfutils/patches/100-musl-compat.patch
index 7427e9a762..25e15047a5 100644
--- a/package/libs/elfutils/patches/100-musl-compat.patch
+++ b/package/libs/elfutils/patches/100-musl-compat.patch
@@ -151,7 +151,7 @@
#include <gelf.h>
--- a/src/ldlex.c
+++ b/src/ldlex.c
-@@ -1099,7 +1099,7 @@ char *ldtext;
+@@ -1106,7 +1106,7 @@ char *ldtext;
#include <assert.h>
#include <ctype.h>
#include <elf.h>
@@ -621,7 +621,7 @@
#include <stdlib.h>
--- a/libcpu/i386_lex.c
+++ b/libcpu/i386_lex.c
-@@ -571,7 +571,7 @@ char *i386_text;
+@@ -578,7 +578,7 @@ char *i386_text;
#endif
#include <ctype.h>
diff --git a/package/libs/elfutils/patches/101-no-fts.patch b/package/libs/elfutils/patches/101-no-fts.patch
index b1b23089fd..6a3e9408d6 100644
--- a/package/libs/elfutils/patches/101-no-fts.patch
+++ b/package/libs/elfutils/patches/101-no-fts.patch
@@ -72,7 +72,7 @@
struct parse_opt *opt = state->hook;
--- a/libdwfl/Makefile.in
+++ b/libdwfl/Makefile.in
-@@ -121,7 +121,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
+@@ -120,7 +120,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
find-debuginfo.c dwfl_build_id_find_elf.c \
@@ -81,7 +81,7 @@
linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
-@@ -150,7 +150,7 @@ am_libdwfl_a_OBJECTS = dwfl_begin.$(OBJE
+@@ -148,7 +148,7 @@ am_libdwfl_a_OBJECTS = dwfl_begin.$(OBJE
dwfl_validate_address.$(OBJEXT) argp-std.$(OBJEXT) \
find-debuginfo.$(OBJEXT) dwfl_build_id_find_elf.$(OBJEXT) \
dwfl_build_id_find_debuginfo.$(OBJEXT) \