aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-02-24 08:52:22 -0800
committerPaul Spooren <mail@aparcar.org>2021-03-25 22:48:10 -1000
commit9390e20dba60753e3bedcd21e69c9cea41f56b17 (patch)
tree3138adf52a4d7365473954debd30d91bbc0dbd51 /package/libs/elfutils
parent27344b378453030f5f35ef4ff5c6ec55c3ff29cb (diff)
downloadupstream-9390e20dba60753e3bedcd21e69c9cea41f56b17.tar.gz
upstream-9390e20dba60753e3bedcd21e69c9cea41f56b17.tar.bz2
upstream-9390e20dba60753e3bedcd21e69c9cea41f56b17.zip
elfutils: enable building with MIPS16
Building with MIPS16 was disabled in 2013 due to an issue with GCC TLS: https://dev.archive.openwrt.org/ticket/13572. But after the problematic GCC version was retired, this change wasn't revisited. Re-enable MIPS16 builds to reduce average elfutils library sizes ~10%. This was compile-tested on malta/mips32be and malta/mips32le, and linked with iproute2 for run-testing. Package sizes follow: Library MIPS16:=0 MIPS16:=1 ------- --------- --------- libelf1 43217 37492 libasm1 12481 11658 libdw1 229723 205793 Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index dd0b8ecdde..3e36dc27b8 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
PKG_VERSION:=0.180
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
@@ -21,7 +21,7 @@ PKG_CPE_ID:=cpe:/a:elfutils_project:elfutils
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
-PKG_USE_MIPS16:=0
+PKG_USE_MIPS16:=1
PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
include $(INCLUDE_DIR)/package.mk