aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-08-04 13:09:12 +0200
committerAlexander Couzens <lynxis@fe80.eu>2017-11-13 01:11:12 +0100
commit6ab45214644166846398e5e520d151c05cc4dd55 (patch)
treedd5f3e1e86754fd51f990352b7ce0d69e84f25ad /package/libs/elfutils
parent164fe697f747aa59a91139425ef9bc82358c4a08 (diff)
downloadupstream-6ab45214644166846398e5e520d151c05cc4dd55.tar.gz
upstream-6ab45214644166846398e5e520d151c05cc4dd55.tar.bz2
upstream-6ab45214644166846398e5e520d151c05cc4dd55.zip
package/elfutils: add CFLAG -Wno-format-nonliteral
When a library is using fortify-packages GCC will complain about "error: format not a string literal, argument types not checked". Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 869513f16f..a726691d3a 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -68,7 +68,7 @@ endif
CONFIGURE_ARGS += \
--without-lzma
-TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result
+TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result -Wno-format-nonliteral
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include