aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2018-11-23 16:40:24 -0800
committerJo-Philipp Wich <jo@mein.io>2018-12-19 10:49:57 +0100
commit4b4e6a04ac918d5cce2d168d9e656f3d2a29ec4b (patch)
tree307a23c3d44b431d71e09f735cb5726a46a70187 /package/libs/elfutils
parent10a2ccb7fceef3a6dea4ece14e6141a807292d5f (diff)
downloadupstream-4b4e6a04ac918d5cce2d168d9e656f3d2a29ec4b.tar.gz
upstream-4b4e6a04ac918d5cce2d168d9e656f3d2a29ec4b.tar.bz2
upstream-4b4e6a04ac918d5cce2d168d9e656f3d2a29ec4b.zip
elfutils: install library files for pkg-config
Support other packages using pkg-config to query existence and details of libelf and libdw libraries at build time. Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 70b26d0003..9fff14d283 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -71,6 +71,9 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libasm*.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdw*.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf*.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libelf.pc $(1)/usr/lib/pkgconfig/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libdw.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libasm/install