aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-05-22 16:08:57 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-05-26 15:42:03 -0700
commit484f768dfa295d9fccd82c57cae00458f32b7182 (patch)
treedd5c456166ac8fa7ace18427be52855347635dfb /package/libs/elfutils
parentb32689afd6a661339861086c669e15c936293cf8 (diff)
downloadupstream-484f768dfa295d9fccd82c57cae00458f32b7182.tar.gz
upstream-484f768dfa295d9fccd82c57cae00458f32b7182.tar.bz2
upstream-484f768dfa295d9fccd82c57cae00458f32b7182.zip
elfutils: Pass -Wno-unused-result to silence warnings as errors
elfutils turns on -Werror by default, and patch 100-musl-compat.patch changes how strerror_r is used and we no longer use the function's return value. This causes the following build error/warning to occur with glibc-based toolchains: dwfl_error.c: In function 'dwfl_errmsg': dwfl_error.c:158:18: error: ignoring return value of 'strerror_r', declared with attribute warn_unused_result [-Werror=unused-result] strerror_r (error & 0xffff, s, sizeof(s)); ^ cc1: all warnings being treated as errors Fixing this would be tricky as there are two possible signatures for strerror_r (XSI and GNU), just turn off unused-result warnings instead. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index d764970c28..869513f16f 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -68,7 +68,7 @@ endif
CONFIGURE_ARGS += \
--without-lzma
-TARGET_CFLAGS += -D_GNU_SOURCE
+TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include