aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-05-01 10:05:20 -0700
committerPetr Štetiar <ynezz@true.cz>2019-05-05 21:11:01 +0200
commit476054102791d395af7225e47e6024573bebf2fe (patch)
treecfe8c247e3f675ed0f469f8787a4f47d1d4da1f1 /package/libs/elfutils
parentb18d1d5d3f28def7cc0b2b01e9951dcacc2b5857 (diff)
downloadupstream-476054102791d395af7225e47e6024573bebf2fe.tar.gz
upstream-476054102791d395af7225e47e6024573bebf2fe.tar.bz2
upstream-476054102791d395af7225e47e6024573bebf2fe.zip
elfutils: Fix compile with uClibc-ng
Probably glibc too. argp_help takes a char *. not const char *. Signed-off-by: Rosen Penev <rosenp@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz> [updated with upstream version of the patch]
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile2
-rw-r--r--package/libs/elfutils/patches/200-uclibc-ng-compat.patch38
2 files changed, 39 insertions, 1 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index c6b1d6df65..e148df096c 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
PKG_VERSION:=0.176
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
diff --git a/package/libs/elfutils/patches/200-uclibc-ng-compat.patch b/package/libs/elfutils/patches/200-uclibc-ng-compat.patch
new file mode 100644
index 0000000000..cb569428c3
--- /dev/null
+++ b/package/libs/elfutils/patches/200-uclibc-ng-compat.patch
@@ -0,0 +1,38 @@
+From: Rosen Penev <rosenp@gmail.com>
+Date: Fri, 3 May 2019 17:59:55 +0000 (-0700)
+Subject: lib/color: Fix compilation with uClibc
+X-Git-Url: https://sourceware.org/git/?p=elfutils.git;a=commitdiff_plain;h=b5e8a481d4c9f9cdb26513784c09c57797fa2f46;hp=4628b0ea03a0d029cccbcda1cbfc450b4c5ad1bf
+
+lib/color: Fix compilation with uClibc
+
+elfutils passed -Werror and this call errors on uClibc with a mismatching
+pointer type. Cast to char * to fix.
+
+Signed-off-by: Rosen Penev <rosenp@gmail.com>
+---
+
+diff --git a/lib/ChangeLog b/lib/ChangeLog
+index 0914b2c..7381860 100644
+--- a/lib/ChangeLog
++++ b/lib/ChangeLog
+@@ -1,3 +1,7 @@
++2019-05-03 Rosen Penev <rosenp@gmail.com>
++
++ * color.c (parse_opt): Cast program_invocation_short_name to char *.
++
+ 2018-11-04 Mark Wielaard <mark@klomp.org>
+
+ * bpf.h: Add BPF_JLT, BPF_JLE, BPF_JSLT and BPF_JSLE.
+diff --git a/lib/color.c b/lib/color.c
+index 9ffbf55..20b9698 100644
+--- a/lib/color.c
++++ b/lib/color.c
+@@ -132,7 +132,7 @@ valid arguments are:\n\
+ - 'auto', 'tty', 'if-tty'\n"),
+ program_invocation_short_name, arg);
+ argp_help (&color_argp, stderr, ARGP_HELP_SEE,
+- program_invocation_short_name);
++ (char *) program_invocation_short_name);
+ exit (EXIT_FAILURE);
+ }
+ }