aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-22 19:17:32 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-24 10:39:30 +0100
commit0e70f69a35fd79be781c859c12487b626e243e96 (patch)
tree2025021f55f831e09f0f102969e01532881b8147 /package/libs/elfutils
parent60558790a2a832265ec041131e851b6648f514d4 (diff)
downloadupstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.gz
upstream-0e70f69a35fd79be781c859c12487b626e243e96.tar.bz2
upstream-0e70f69a35fd79be781c859c12487b626e243e96.zip
treewide: revise library packaging
- Annotate versionless libraries (such as libubox, libuci etc.) with a fixed ABI_VERSION resembling the source date of the last incompatible change - Annotate packages shipping versioned library objects with ABI_VERSION - Stop shipping unversioned library symlinks for packages with ABI_VERSION Ref: https://openwrt.org/docs/guide-developer/package-policies#shared_libraries Ref: https://github.com/KanjiMonster/maintainer-tools/blob/master/check-abi-versions.pl Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 885882669e..3ee1c472a1 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
PKG_VERSION:=0.175
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
@@ -33,6 +33,7 @@ define Package/elfutils/Default
CATEGORY:=Libraries
TITLE:=ELF manipulation libraries
URL:=https://fedorahosted.org/elfutils/
+ ABI_VERSION:=1
endef
define Package/libasm
@@ -79,17 +80,17 @@ endef
define Package/libasm/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libasm*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libasm*.so.* $(1)/usr/lib/
endef
define Package/libdw/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdw*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdw*.so.* $(1)/usr/lib/
endef
define Package/libelf1/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf*.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libasm))