aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils
diff options
context:
space:
mode:
authorMatt Merhar <mattmerhar@protonmail.com>2019-02-26 08:05:07 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-26 23:20:04 +0100
commit0d1d5880c0b228989a40e5e647fc9c924d086865 (patch)
tree3b9a985464d8934b1255d77ce03516fc0585a5ad /package/libs/elfutils
parent00d89b4a89936cfb86aa57fbb99f33efda80981f (diff)
downloadupstream-0d1d5880c0b228989a40e5e647fc9c924d086865.tar.gz
upstream-0d1d5880c0b228989a40e5e647fc9c924d086865.tar.bz2
upstream-0d1d5880c0b228989a40e5e647fc9c924d086865.zip
elfutils: fix install .so glob
Only libelf was being packaged correctly - libdw and libasm included just the symlinks. Signed-off-by: Matt Merhar <mattmerhar@protonmail.com>
Diffstat (limited to 'package/libs/elfutils')
-rw-r--r--package/libs/elfutils/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 5b5f641a10..0b3cecdfbd 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
PKG_VERSION:=0.175
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
@@ -81,12 +81,12 @@ endef
define Package/libasm/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libasm*.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libasm{-*.so,*.so.*} $(1)/usr/lib/
endef
define Package/libdw/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdw*.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdw{-*.so,*.so.*} $(1)/usr/lib/
endef
define Package/libelf/install