aboutsummaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-24 10:36:25 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-24 10:36:25 +0000
commitf94411e910004035c83c3b8261b0790590aaba37 (patch)
treed3fd2b6717b736f1da3ea38940cae48d5d447053 /package/libpcap
parent50d2a84a2157079a4e040a90fbd062f4b2a98cb8 (diff)
downloadupstream-f94411e910004035c83c3b8261b0790590aaba37.tar.gz
upstream-f94411e910004035c83c3b8261b0790590aaba37.tar.bz2
upstream-f94411e910004035c83c3b8261b0790590aaba37.zip
libpcap: add -fpic, refresh patches
SVN-Revision: 26999
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/Makefile1
-rw-r--r--package/libpcap/patches/102-makefile_disable_manpages.patch2
-rw-r--r--package/libpcap/patches/201-space_optimization.patch6
-rw-r--r--package/libpcap/patches/202-protocol_api.patch8
4 files changed, 9 insertions, 8 deletions
diff --git a/package/libpcap/Makefile b/package/libpcap/Makefile
index c2a3b74b1c..75c3ddf3c6 100644
--- a/package/libpcap/Makefile
+++ b/package/libpcap/Makefile
@@ -38,6 +38,7 @@ define Package/libpcap/config
endef
TARGET_CFLAGS += \
+ $(FPIC) \
-ffunction-sections \
-fdata-sections
diff --git a/package/libpcap/patches/102-makefile_disable_manpages.patch b/package/libpcap/patches/102-makefile_disable_manpages.patch
index e9cde4f46a..7756c99ead 100644
--- a/package/libpcap/patches/102-makefile_disable_manpages.patch
+++ b/package/libpcap/patches/102-makefile_disable_manpages.patch
@@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -539,62 +539,12 @@ install: install-shared install-archive
+@@ -539,62 +539,12 @@ install: install-shared install-archive
(mkdir -p $(DESTDIR)$(includedir); chmod 755 $(DESTDIR)$(includedir))
[ -d $(DESTDIR)$(includedir)/pcap ] || \
(mkdir -p $(DESTDIR)$(includedir)/pcap; chmod 755 $(DESTDIR)$(includedir)/pcap)
diff --git a/package/libpcap/patches/201-space_optimization.patch b/package/libpcap/patches/201-space_optimization.patch
index 29c293b623..f3eec4c839 100644
--- a/package/libpcap/patches/201-space_optimization.patch
+++ b/package/libpcap/patches/201-space_optimization.patch
@@ -1,6 +1,6 @@
--- a/gencode.c
+++ b/gencode.c
-@@ -439,20 +439,6 @@ pcap_compile_nopcap(int snaplen_arg, int
+@@ -491,20 +491,6 @@ pcap_compile_nopcap(int snaplen_arg, int
}
/*
@@ -23,7 +23,7 @@
* back to another unresolved block (or nil). At least one of the fields
--- a/pcap.c
+++ b/pcap.c
-@@ -698,6 +698,59 @@ static const u_char charmap[] = {
+@@ -748,6 +748,59 @@ static const u_char charmap[] = {
(u_char)'\374', (u_char)'\375', (u_char)'\376', (u_char)'\377',
};
@@ -85,7 +85,7 @@
{
--- a/optimize.c
+++ b/optimize.c
-@@ -2278,45 +2278,6 @@ icode_to_fcode(root, lenp)
+@@ -2292,45 +2292,6 @@ icode_to_fcode(root, lenp)
return fp;
}
diff --git a/package/libpcap/patches/202-protocol_api.patch b/package/libpcap/patches/202-protocol_api.patch
index 892aeb7e0d..6d59b495d0 100644
--- a/package/libpcap/patches/202-protocol_api.patch
+++ b/package/libpcap/patches/202-protocol_api.patch
@@ -105,11 +105,10 @@
return (p);
}
-@@ -317,6 +319,15 @@ pcap_set_buffer_size(pcap_t *p, int buff
- return 0;
+@@ -318,6 +320,15 @@ pcap_set_buffer_size(pcap_t *p, int buff
}
-+int
+ int
+pcap_set_protocol(pcap_t *p, unsigned short proto)
+{
+ if (pcap_check_activated(p))
@@ -118,9 +117,10 @@
+ return 0;
+}
+
- int
++int
pcap_activate(pcap_t *p)
{
+ int status;
--- a/pcap/pcap.h
+++ b/pcap/pcap.h
@@ -68,6 +68,7 @@ extern "C" {