aboutsummaryrefslogtreecommitdiffstats
path: root/package/libnl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:56 +0000
commit67dd9a73dcb62e5b072244dddd7b19d521e20e67 (patch)
tree3d0dbf6e0906fe0c7ef1446c08254effa561a40b /package/libnl
parent224760dee7a5f0913d894b7a23cc8d94b353dd70 (diff)
downloadupstream-67dd9a73dcb62e5b072244dddd7b19d521e20e67.tar.gz
upstream-67dd9a73dcb62e5b072244dddd7b19d521e20e67.tar.bz2
upstream-67dd9a73dcb62e5b072244dddd7b19d521e20e67.zip
fix up hostapd for mac80211
SVN-Revision: 9554
Diffstat (limited to 'package/libnl')
-rw-r--r--package/libnl/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/package/libnl/Makefile b/package/libnl/Makefile
index 9f334108ed..28958f4a51 100644
--- a/package/libnl/Makefile
+++ b/package/libnl/Makefile
@@ -36,16 +36,19 @@ define Build/Compile
install
endef
-define Build/InstallDev
+ifneq ($(CONFIG_LINUX_2_6_23),)
+ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
-endef
+ $(CP) $(PKG_BUILD_DIR)/include/linux $(1)/usr/include/
+ endef
-define Build/UninstallDev
-endef
+ define Build/UninstallDev
+ endef
-define Package/libnl/install
+ define Package/libnl/install
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libnl.so.1 $(1)/usr/lib/
-endef
+ endef
+endif
$(eval $(call BuildPackage,libnl))