aboutsummaryrefslogtreecommitdiffstats
path: root/package/keynote/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-29 19:19:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-29 19:19:22 +0000
commitad0da135fda99815a056f3c726ad0d20ae83db47 (patch)
tree82d2f025c330342e5be4a3b5a0883bc0b6e655bd /package/keynote/Makefile
parent4cf73979dea390d1d91a409f71af3e42649a203d (diff)
downloadupstream-ad0da135fda99815a056f3c726ad0d20ae83db47.tar.gz
upstream-ad0da135fda99815a056f3c726ad0d20ae83db47.tar.bz2
upstream-ad0da135fda99815a056f3c726ad0d20ae83db47.zip
fix keynote compile
SVN-Revision: 10030
Diffstat (limited to 'package/keynote/Makefile')
-rw-r--r--package/keynote/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/keynote/Makefile b/package/keynote/Makefile
index 5b27257b4a..56bbeb0e58 100644
--- a/package/keynote/Makefile
+++ b/package/keynote/Makefile
@@ -40,6 +40,8 @@ CONFIGURE_ARGS += \
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)"
+TARGET_CFLAGS += -Dbcopy=memmove -Dindex\(s,c\)=strchr\(s,c\)
+
define Build/InstallDev
mkdir -p $(1)/usr/include/keynote
$(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(1)/usr/include/keynote/