aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorGlen Huang <me@glenhuang.com>2023-04-26 22:38:24 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-29 12:30:30 +0200
commite1c0bda3fc9a01c461591864bd0163b052b5783d (patch)
treed2f4288a5678764e3d3ccb51b35a10b28c96e8af /package/kernel
parentec6f80663ed80e50844d0c032121e0bec46ff297 (diff)
downloadupstream-e1c0bda3fc9a01c461591864bd0163b052b5783d.tar.gz
upstream-e1c0bda3fc9a01c461591864bd0163b052b5783d.tar.bz2
upstream-e1c0bda3fc9a01c461591864bd0163b052b5783d.zip
kernel: crypto: crypto-rng: select SHA512 for >= 5.14.0
drbg swtiched to use HMAC(SHA-512) since 5.14.0 https://github.com/torvalds/linux/commit/5261cdf457ce3635bf18d393a3c1991dcfaf9d02 Signed-off-by: Glen Huang <me@glenhuang.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/crypto.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 4950b94c62..98bcb9e874 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -827,7 +827,9 @@ $(eval $(call KernelPackage,crypto-rmd160))
define KernelPackage/crypto-rng
TITLE:=CryptoAPI random number generation
- DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha256
+ DEPENDS:=+kmod-crypto-hash +kmod-crypto-hmac \
+ +LINUX_5_10:kmod-crypto-sha256 \
+ +LINUX_5_15:kmod-crypto-sha512
KCONFIG:= \
CONFIG_CRYPTO_DRBG \
CONFIG_CRYPTO_DRBG_HMAC=y \